Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

In my InDesign document, figure captions are bold when they appear in the body of the document, and non-bold when they appear in the list of figures. But when I need to italicize text in a figure caption, this results in bold text in the list of figures.

How can I have bold italic text in the figure caption and non-bold italic text in the list of figures?

Here's my setup:

  • InDesign CS5
  • The paragraph style for figure captions sets the font style to bold
  • The list of figures is an automatically-generated table of contents. The paragraph style for TOC entries has a font style of regular.

Styles I'm using

Paragraph styles

Figure Caption: Font family: Helvetica. Font style: Bold.

List of Figures: Font family: Helvetica. Font style: Regular.

Character styles

Oblique: Font style: Oblique.

Bold + Oblique: Font style: Bold Oblique.

Except where I state otherwise, text uses a character style of [None].

Desired result

This is what I want to have:

Caption: Figure 7. Excerpt from Routes I Know

List of figures: Figure 7. Excerpt from Routes I Know..................31

First Try

I used the Oblique character style to italicize the text in the caption. So the Figure Caption paragraph style makes the text bold, and the Oblique character style makes (part of) the text italic. The resulting text is italic, but not bold.

Caption: Figure 7. Excerpt from Routes I Know

List of figures: Figure 7. Excerpt from Routes I Know..................31

Second try

I used the Bold + Oblique character style on the text in the caption. Both the bold and italic apply to the list of figures.

Caption: Figure 7. Excerpt from Routes I Know

List of figures: Figure 7. Excerpt from Routes I Know..................31

EDIT: Added more info about the paragraph styles I'm using

share|improve this question
    
I'm still a bit fuzzy on what you put into each set of styles, but it sounds like you're going to have to spend some time tweaking the para and character styles with oblique and bold oblique weights. You just have to try it repeatedly with different settings to see what works. –  Lauren Ipsum Nov 4 '12 at 1:14
    
Thanks for looking at this. I've updated the question with more details about the styles I'm using. And I've tried messing around with the settings, but it's not getting me what I want. –  Evan Nov 5 '12 at 19:42
add comment

2 Answers

up vote 3 down vote accepted

I am still not sure I understand the question etirely but I think the ploblem is that Bold Italic is its own Style and not Italic + Bold (like it is e.g. in a Word Document or this Editor). So the Character style cannot be passed down from Italic to Bold Italic.

I still don't have a good solution but here is my workaround:

Create the Table of Contents, Copy it into a new document, delete the bold italic character style and when promted, replace it with the italic character style.

It's an ugly solution but a quick fix (as opposed to making changes in ever line in the TOC). I'll look into this though, interesting problem.

share|improve this answer
add comment

have you tried zapping your font caches for Adobe InDesign? or checking the actual font files to make sure they are not corrupted in anyway? I also assume your OS and CS5 of InDesign are both on the latest free updates?

share|improve this answer
    
Not sure that has any influence on the issue as it is reproducable on my machine and is actually about paragraph styles... –  KMSTR Nov 9 '12 at 9:59
    
Ah, ok, did not catch that - still useful advice in general though - can never hurt, right! –  David Dilling Nov 9 '12 at 10:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.