Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have a set of white label PDF forms that I need to brand for our company. The initial document is 6 pages, 316KB, and already has a full set of fillable fields. In a perfect world, I just open up the first page, replace the header with a header that has our logo, save, and be on my merry way. If the file size jumps a bit, I can just go into Acrobat and "Reduce File Size."

However, the results were really bad. I think I about doubled the file size by doing this on one page alone. I thought the inflated size might have something to do with fonts since I had to "Find Fonts" in Illustrator, so I outlined my company's header (it used a different font) and went through every page to get all of the fonts on the same page. The results were worse: 2.49MB!

PDF file sizes have always felt like a dark art to me, and I want that to change. If my Photoshop file is huge, I know it's because of document dimensions, layers, and such. When my AI file sizes got out of control, I learned that unchecking "save PDF compatible version" would help out a lot. When I'm making my own PDFs and I want to export them, I have a solid grasp on downsampling and such to get a good file size.

But when it comes to editing PDFs, I really don't know how file sizes work. I don't know what "Reduce File Size" means. I don't know why sometimes a file size will double or triple and why it sometimes won't, and if PDFs are embedding duplicate data, I don't know how to get it out.

So, how do I keep file sizes down when editing PDFs?

share|improve this question

3 Answers 3

up vote 7 down vote accepted

Look around for the Audit space usage ... option (explained here). In newer versions it is oddly hidden under Save as > Optimized PDF. That will tell you exactly where the bloat is coming from. You can also use the Optimized PDF option to crank the size down in very targeted ways.

Given the big before/after shift, the culprit is probably the image you're embedding. Try exporting that file in various formats (PDF, jpg, png) and then import it.

share|improve this answer
    
Thanks for this; I'll explore. I'd like to clarify though that I didn't embed an image in this document; the logo and text are vector. I mentioned downsampling in general terms; my wording could have been better. –  Brendan Nov 9 '12 at 17:26
    
My wording could have been clearer too. Point is, whatever branding you're dropping into the file is probably causing the file size increase. Trying vector vs raster in various formats may take you in the right direction. –  plainclothes Nov 9 '12 at 17:32
    
Whoa! How did I not know about the PDF Optimizer feature? I'm so glad I asked. I had 96% locked up in "Piece Information"; discarding user data drastically improved the file size. Thanks! –  Brendan Nov 9 '12 at 17:36
4  
It used to be a very obvious feature. If you didn't heavily use older versions of Acrobat, it's an easy thing to miss. Adobe isn't big on UX ;) –  plainclothes Nov 9 '12 at 17:51

I've found out that unticking the 'Preserve Illustrator Editing Capabilities' box under the General tab gives me a smaller size pdf.

If you want to preserve Illustrator editing capabilities, you may run ACTIONS_Delete Unused Panel Items, this may help in getting a reduced file size when you save your pdf.

share|improve this answer

You can also select whther or not to allow reading of the PDF from older versions of adobe reader or acrobat. The more backwards compatibility that you have the bigger your file will be. You should find that if you say restrict the compatibility to the latest version of adobe then the file size will be smaller than if you allow backwards compatibility to say Adobe Acrobat 4.

Its just a small thing but it may help...

share|improve this answer
1  
I used to use that trick all the time. I saved most of my files down to Acrobat 4. These days it seems like a lot of the PDFs I've produced actually go up in size with backward compatibility. It's especially apparent where transparency needs to be flattened. Maybe the newer versions are doing a better job with compression. –  plainclothes Nov 9 '12 at 17:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.