Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

Whenever I select an object by clicking on it in Illustrator CS6, the second I move my mouse it moves the object. Is there a way around this? I just need to select an object and then change it's color or font but as soon as I move my mouse, the object is moved 3-4 pixels.

share|improve this question

closed as off-topic by Scott, Vincent, Benteh, JohnB Apr 4 at 13:23

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This appears to be a tech support question about fixing technology to work as advertised. Please edit the question so that it pertains to using technology to solve a design problem. You may want to check if it hasn't already been asked in Super User. In many cases, contacting the manufacturer is the quickest option." – Scott, Vincent, Benteh, JohnB
If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers 3

I figured it out based on this post: http://forums.adobe.com/thread/758287.

I had Rightzoom running in the background and once I turned it off, all was well. I hope this helps anyone else and thanks for your help @tehMacDawg.

Whew!

share|improve this answer
    
Rightzoom was the culprit for me too. Added it to the exceptions list and all is well in Illustrator land. –  user21453 Apr 4 at 3:44

If the objects move only a few pixels, might this be related to the notorious Align to Pixel Grid option? When creating a new Illustrator document for screen media, there is this option in the 'New' dialog box that is activated by default. (It helps avoiding blurry lines in the artwork when creating graphics for screens...) If you've been creating a new document, do this again and uncheck that option. Otherwise, it's possible to activate/deactivate this automatic re-alignment for each object using the Transform panel (you need to expand the options of the Transform panel via the drop-down menu in the upper right corner.)

share|improve this answer

Sounds like an issue with the mouse, not Illustrator. There is absolutely no "sticky click" option anywhere in Illustrator

:)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.