Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

How do I get rid of the thin artifact outlines around my live paint fills?

enter image description here

The first screenshot shows the wireframe view (CTRL+Y) in Illustrator. The second screenshot shows the normal view in Illustrator. The white artifact lines are very thin, but still visible. The third screenshot shows the pasted result in Photoshop, scaled down. When the drawing is scaled down in Photoshop, the outlines become more evident and make the design look really bad.

This is what I've been doing:

  1. In Illustrator, I used calligraphic brush to draw the outlines of my character.
  2. Converted the whole character into a live paint group.
  3. Filled in my character with the live paint bucket.
  4. Copy and pasted the character as pixels into Photoshop.
share|improve this question

2 Answers 2

up vote 5 down vote accepted

This is generally do to Anti-aliasing in the Illustrator preferences. However, even disabling the anti-aliasing won't fill those gaps in many cases.

Based upon your artwork, I'd use the Shape Builder Tool rather than the Live Paint Tool. You really only need two shapes.

Simply select the Shape Builder Tool, click a swatch or pick a color, and click-drag across shapes which should be merged. Then change colors for the tongue (presumably) and just click that area to fill it.

Shape Builder

This will combine those outer shapes and remove the anti-aliasing gaps you're seeing when pasting into Photoshop. Of course you could simply duplicate the layer a couple times in Photoshop and then merge the duplicates. This will fill in those anti-aliasing gaps as well.

share|improve this answer
    
Cool technique, but my actual drawing is quite complex. I have hundreds of areas to fill. That's why I chose to use the live paint tool to quickly fill everything. –  JoJo Dec 17 '12 at 16:13
    
Shape Builder fills too, as you can see above. But it may be easier for you to just duplicate and merge the layer in Photoshop to remove the gaps. There really isn't a quick and easy way in Illustrator to remove those anti-aliasing gaps. –  Scott Dec 17 '12 at 18:38

I've been having this same issue as well. I couldn't seem to find a good solution. But it seems that exporting from Illustrator as a Photoshop PSD removes those lines.

Settings: - Resolution: High (300 ppi) - Flat Image - Anti-Aliasing: Type Optimized (Hinted)

I really wish I could paste as a smart object, but that seems to have broken with the CS6 update. If you have any other info please share.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.