Sign up ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I can't find the Pixel Grid option like I would have in CS5. I just upgraded. Any ideas?

enter image description here

share|improve this question

5 Answers 5

I had this problem and what fixed it for me was going into Edit > Preferences > Performance and then changing my cache levels from 4 to 6, then simply restart.

Now i have the pixel grid option where as before I didn't. Happy PhotoShopping!

share|improve this answer
Hi Theo, welcome to GDSE and thanks for your answer. If you have any questions, please see the help center or ping one of us in chat once your reputation is sufficient (20). Keep contributing and enjoy the site! – Vincent Dec 1 '14 at 9:48

View > Show > Show Pixel Grid

Note: The pixel grid is only visible when zoomed in on any document. You won't see it at 100% in most cases.


Another possibility, brought up by Lèse majesté, is OpenGL preferences. Do you have a video card which meets the minimum system requirements? If you view Preferences > Performance, under Graphic Processor Settings, are those enabled?

share|improve this answer
It's very unlikely that this is due to a fowled up installation. It's more likely he just doesn't have OpenGL/GPU-acceleration enabled. – Lèse majesté Dec 24 '12 at 3:31

Click on Show Extras Options at the bottom of the tab, then check the Pixel Grid box.

share|improve this answer

Go into Edit > Preferences > Guides, Grid, Slices... Then change some things in Grid, like Gridlines every {number} pixels

share|improve this answer
How does this solve the problem? Does the pixel grid option come back in the menu? – Bart Arondson Mar 19 '14 at 21:35

I had this same problem when I plugged in my external monitor. Restarting Photoshop fixed the missing Show Pixel Grid menu item.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.