Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

I have created an image and added some effects to it but now when I try to save it as PNG there's a white frame addon to it. I've tested a few things and realised that this behavior happens when I convert the image to a smart object. How can I save the image as PNG and keep the image "as is" without the extra white frame?

Update: I've added a side by side picture. Left side is the psd, right side is the same PSD that was saved as PNG and imported back to the picture.

PNG:

enter image description here

Thanks

share|improve this question
    
Could you add the resulting PNG. I can't reproduce this result. –  KMSTR Jan 18 '13 at 15:13
    
Just did. If you'll put both of them on black background you'll see the difference. –  Segev Jan 18 '13 at 15:32
add comment

2 Answers

up vote 1 down vote accepted

I think the reason this is a mystery to you is you've not really grasped what Blend Modes are in general, and Overlay in particular.

Anything in Overlay mode is invisible against black (or white). Change your black layer in the PSD to any color or a dark grey and you'll see the white outline. Overlay doesn't affect pure black, nor pure white. You can demonstrate this by painting with a black brush in Overlay mode on a white layer, or a white brush in Overlay mode on a black layer: nothing happens. That's just the way the math of Overlay works.

The problem, and the thing that's confusing you, is that your Drop Shadow only goes into Overlay mode when you turn on the layer below. When that layer is off, it's not in Overlay mode, it's in Normal mode.

Here's why:

Blend modes are blend modes. A "blend," by definition, requires at least two ingredients. In Photoshop, a layer or an effect blends with something below it. There must be at least one non-empty layer to blend with, otherwise the layer or effect displays in Normal mode. That's why you can't assign a blend mode to a background layer: with nothing below it, it can't ever blend.

Set any Photoshop layer to Overlay (or any blend mode). If you have no layers or only empty layers below it, you will not see any change; the layer has nothing to blend with. Add a layer below and fill with a color. Now you will see a change, because Photoshop now has a second layer to use in the blend calculation.

Your PSD clock has a white drop shadow. You should now have realized that it is a white drop shadow in Normal mode, regardless of what blend mode you assign to it, until you turn on the non-transparent layer below it. Because you're using a black layer, the Overlay mode white simply disappears in the blend.

PNG is a web format. It contains transparency, but browsers, HTML and CSS don't understand blend modes so there is no reason for a png to contain that information. When Photoshop exports your clock-with-transparent-background to png, it exports the white "shadow" in Normal mode because it is in Normal mode, and because any blend mode information is meaningless to png.

share|improve this answer
add comment

The "white frame" you are seeing is the Drop Shadow effect you have applied to the layer:

enter image description here

Remove that effect and you will not see it when you export to PNG.

share|improve this answer
    
I need that drop shadow if i want the clock to look like it's sunk in. Please see the new picture in my updated question –  Segev Jan 18 '13 at 16:18
    
@Sha I suspect the reason it looks different when exported is because of the way alpha transparency is saved in PNG. You will not see the white drop-shadow if you add in a colored background then export as PNG. Are you sure you want to make it look "sunk in"? A drop shadow will make it pop-out. I would suggest a different solution to make it appear sunk in: Create an “pressed in” look –  JohnB Jan 18 '13 at 16:28
    
I add no idea alpha transparency is saved differently in png. Adding colored background does solve it but I need it transparent. What the drop shadow does in the picture above is adding more sunk feel imo. I'd love to get more info on why it saved differently and if there's a walk-around to it besides changing the original picture. –  Segev Jan 18 '13 at 17:03
    
@Sha, I believe the biggest culprit is the Blend Mode. With Overlay, light parts of the picture become lighter and dark parts become darker. I do not think this type of behavior is supported in PNG transparency, so Photoshop "dumbs" it down when you export it. Could you achieve the effect you want using a different Blend Mode, such as Multiply? –  JohnB Jan 18 '13 at 17:33
    
Hmm, Changing the Drop Shadow -> Blend Mode to Multiply didn't helped. I can still see the white outline after saving as PNG. –  Segev Jan 18 '13 at 18:03
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.