Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

I'm not sure whether I should be asking this kind of question here, but...

When I'm working in Photoshop (CS5 currently, have had it with previous versions as well), when I've zoomed in on the file and have the hand tool selected, Photoshop sometimes zooms out as I drag with the hand tool. It zooms to 'fit screen' size, and zooms back in when i release the mouse button. It does so at random times, and at those times I'm not pressing any buttons other than the left mouse button.

It's really driving me nuts, does any of you know if this is fixable?

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

You are experiencing a Bird's-Eye View feature's bug:

Here's a way to reproduce this glitch: while zoomed, hold down ANY tool shortcut you're not currently using (i.e. hold B while you have Clone Stamp selected) and, at the same time, try to use the spacebar pan.

It still isn't fixed in Photoshop 13.0.1 (which ships with CS6) and the only way to get rid of this bug at the moment is to disable OpenGL features*: Preferences => Performance... => Graphics Processor Settings block => uncheck Use Graphics Processor checkbox and restart Photoshop.


* I would highly suggest not doing so though, as it will disable many neat features and optimisations.
share|improve this answer
    
InDesign does this too and it makes me crazy. Also usually scares the crap out of me as I'm trying to work. I'm going along and dragging and suddenly AAHHHHHHHaaahhhhAAAAAHHHH!! –  Lauren Ipsum Apr 5 '13 at 20:49
    
@Cust0dian Thanks for your amazing edit in the other question! You did an awesome job :) –  Yisela Apr 5 '13 at 22:54
    
@Yisela thanks, just in the mood to share the knowledge. :) –  Cust0dian Apr 5 '13 at 23:11
    
Thanks for the clarification. I just hope Adobe will fix this in the next version of PS (and InDesign). –  poepje Apr 6 '13 at 21:20
add comment

The Bird's Eye view is normally activated by holding H while clicking and dragging. There is a bug that makes this feature sticky. Press and let go of Alt, the menu bar quick access letters will remain underscored. Then press H, the Help menu opens up. Don't click the menu, click anywhere on your picture and now the Bird's Eye view is sticky. Press H to return to normal.

  1. Alt (press and let go)
  2. H
  3. click on your picture, not the drop down menu
    ( Bird's Eye view is sticky )
  4. H to unstick
share|improve this answer
add comment

I've never heard of this problem before. You could try resetting your preferences. Hold down Alt, Ctrl, and Shift keys (Mac: Command, Option, Shift) while starting up Photoshop. A dialog box will appear asking if you wish to delete the preferences/settings file.

share|improve this answer
    
Thanks, however I'm pretty sure it's a feature rather than a bug. This is because no other zoom or pan tool shows a rectangle that shows what part you were originally were zoomed to. –  poepje Feb 5 '13 at 16:16
    
I tried your solution though, but it doesn't ask for a reset?! –  poepje Feb 5 '13 at 16:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.