Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I came across this problem after printscreening a website with a gradient background. Initially, I was shocked to find that the background was showing those black pixels, and thought something might be wrong with my GPU so I decided to investigate a little and found out that the image's bit depth was 24 and photoshop was opening it in 8bit mode (maybe because photoshop doesn't have a 24bit mode?).

I was wondering: How come when I save the image in 8bit mode it doesn't show those black pixels, in programs like windows photo viewer and paint? Why are they showing only in photoshop? Shouldn't photoshop find comparable colors to fill in instead of black?

When I change the mode to 32bit those black pixels disappear. Also, when sampling those black spots with the eyedrop I am getting the correct color.

This is the image I was speaking about:

the image in question

And here's what I am seeing:

enter image description here

share|improve this question
    
Interesting, the black areas in the screenshot don't appear to be all the one colour, but appear in bands in separate colour. This might slightly further my suspicions that this is a gamut issue, because it looks like it might be happening to certain colours. But I still have no idea if I'm right. It could also be a bug. –  thomasrutter Jan 31 '13 at 3:04
    
also you stated that it doesn't happen in your photoshop with the same image. so I don't think it is a gamut issue –  Jake Jan 31 '13 at 3:08
    
When I say gamut issue, I mean that you have enabled proof colours in Photoshop (which should be normally off, and on only to preview) and out of gamut warnings, and you have set up a strange combination of colour spaces in the image itself. This is just a PNG so there would be no way for me to know what settings you had applied to Photoshop and/or the PSD. –  thomasrutter Jan 31 '13 at 3:10
    
turns out this is related to gamut warning. when I have gamut warning off it displays this black pixels but when it's on it shows the right colors. should I normally have gamut warning on or off? (btw to me it would make more sense that turning gamut warning on would show me those black pixels so I know those spots are out of gamut but it seems to be the other way around) –  Jake Jan 31 '13 at 3:18
    
It's normal to have proof colours and gamut warnings turned OFF, and only turn them on when you're testing specific issues related to differences in colour space between the image's native colour space and the output device/printer. If you are not even doing this and/or have not specifically set up your colour spaces, turning these on is only going to give incorrect/misleading results. By the way, it's normal for the working colour space for an image to be sRGB (sRGB IEC61966-2.1 in Photoshop) as a default, particular when working for the web or desktop. –  thomasrutter Jan 31 '13 at 3:27

3 Answers 3

up vote 0 down vote accepted

It was a problem with my GPU driver. I have an ATI HD7950 and I upgraded the driver to version 13.1 which apparently caused this issue with photoshop. the fix is to either downgrade the driver to version 12.8 or upgrade to the beta driver (13.2) I hope this would help anyone having the same issue.

share|improve this answer
    
Replacing the driver (13.1 to 13.4) was the solution for my ATi 7750 as well. Thank you! –  user13510 Jun 21 '13 at 11:17

This is a long shot, but the black pixels you're seeing aren't out of gamut warnings, are they?

These occur when you have set a print/output colour space for the image that is different to the image's native colour space and some of the areas in the image fall outside the print colour space. If the image is wide gamut like Adobe RGB and it thinks it needs to output to a different colour space, deep blue-green colours are likely to fall outside that colour space.

If it is this (and I am still not very confident it is, until I see a screenshot) then these are warnings only and can be turned off within Photoshop (by disabling proof colours, perhaps?)

As Scott says, 24 bit is just another way of saying 8 bits per colour so it's not that.

share|improve this answer

8bit = 24 bit.
It's merely a different way of displaying it.

8 Bit means 8 bits per channel.

8 Bits per channel means 8R 8G 8B (8x3) = 24bits.

Photoshop merely uses the former which is why the menu in Photoshop reads "8 bits / Channel"

What it sounds like you are referring to is a 32bit image. 32bit images also have 8bits for alpha (transparency). 24 bit images do not have transparency.

Photoshop can have trouble with some formats. And you can lose transparency depending up how you grabbed the image. If transparency isn't transferred, Photoshop will substitute black, hence black in Photoshop where transparency should be. Most often it's due to a color being set as transparent in the image. Many apps allow you to define the color for transparency. Photoshop does not, and due to that, can fail to interpret that setting.

GIF images are notorious for losing transparency when opened with Photoshop. But it's a common thing with PNG24 images as well if an app strips enough metadata from the png, Photoshop won't read the transparency. The solution is to pen the image and resave it in a desktop application which does see the transparency. Afterward Photoshop generally displays the image correctly.

share|improve this answer
    
I don't think it has anything to do with transparency. found out this wasn't a single problem with just one image. it is affecting all my images! for example if I open a new photoshop document and set the background to #00dc62 it shows the color as black instead of this neon green. when I change the color mode to 32 bit it shows the correct color and also when I turn gamut warning on(so theres a V next to it) it also shows the correct color –  Jake Feb 3 '13 at 2:26

protected by Community Oct 12 '13 at 20:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.