Sign up ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

How can I make my vector graphics anti-aliased in illustrator? My paths always turn out jagged. Is there an option like in Adobe Fireworks to smoothen[remove the jaged edges] my paths?

share|improve this question

migrated from Feb 10 '13 at 18:34

This question came from our site for professional and enthusiast programmers.

can you show a sample? Is anti-aliasing checked in the Illustrator preferences? Possible duplicate of Illustrator Vector Graphics Appearing Pixellated –  Scott Feb 10 '13 at 20:36
Same problem. Upgraded to CC2015 from CC2014. Anti-aliasing ticked in General preferences. On screen, all the paths are jagged and so annoying that I've now started working in CS5! (CC2015 over written CC2014, which anti-aliased ok). –  PatrickM Jul 14 at 15:55

4 Answers 4

up vote 2 down vote accepted

In Edit > Preferences > General there is an option that toggles Anti-Aliasing for art as it is displayed on screen while you work.

Under Effect > Document Raster Effect Settings there is a checkbox for Anti-Aliasing that controls to some degree the outcome of the file once it is saved to a non-vector format (ie. jpg, gif, png).

Depending on which file type you save to there are often more options that can affect the appearance of jagged lines in your art. What you are saving can influence how you should use these settings, as you may want to do things that may seem counter intuitive. Small type for example may need no or very little anti-aliasing or it will become muddy. Also take into consideration the PPI of the file. Low resolution images will appear have jagged edges even with anti-aliasing—the human eye can detect up to 150 ppi, at 72 ppi the pixels will not resolve at a normal viewing distance.

share|improve this answer
But this is for when you place raster's within Illustrator, right?.. Not for the actual vectors? –  Patrik Alienus Feb 13 '13 at 0:19
I was under the impression that it applied to all art. Since Illustrator has to rasterize all the art in order to display it I would assume it was running these anti-aliasing algorithms on everything. But that is simply my logical conclusion on the matter. –  brnnnrsmssn Feb 18 '13 at 22:22
Without knowing when the "jagged edges" are introduced it might be that his Document Raster Ëffects Settings are the source of the problem he has. There is also an Anti-Alias option in that menu as well. Some quick checking confirms that the Edit > Preferences > General > Anti-Alias option does affect the appearance of vectors on screen as you work with them. The Effect > Document Raster Effects Settings > Anti-Alias affects the art as it is saved to another (rasterized) format. But even with anti-aliasing a low resolution (72ppi) will be jagged even at no zoom. –  brnnnrsmssn Feb 18 '13 at 22:48
![My design logo Alex_graphics][1] [1]: That is the image I was referencing and well, I appreciate it seems the problem was linked to "he Effect > Document Raster Effects Settings > Anti-Alias affects" settings. Saved my time :) –  Bosco Mabutao Feb 19 '13 at 2:38
@BoscoMabutao If this answer worked for you, can you mark it as 'Accepted' with the tick icon, so we know the problem is solved and others can see which answer worked? –  user568458 Feb 19 '13 at 17:30

This worked for me: If you are having aliasing problems in Illustrator CC 2015, ⌘+E toggles between GPU and CPU previewing. CPU's anti-aliasing is 1000% better.

share|improve this answer
This was exactly my problem. In one of the latest updates, my vectors started looking jagged. ⌘+E solved that problem! Thank you! –  mhulse Sep 4 at 15:54

To avoid jagged lines when you "Save for Web & Devices" in the tab "Image Size" set combo box at the bottom to "Art optimized" or "Type optimized" depending on the content of your image (by default this combo box is set to "None").

share|improve this answer

Vector graphics do not have anti-aliasing as they are not raster graphics. If you have jagged edges, it might be your display performance setting. I've seen that in InDesign, not sure if it exists in Illustrator at all, actually.

If you are talking about when you import or paste your vector into Photoshop and it produces jagged edges there, that's a different question entirely.

Please provide a screenshot if you can.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.