Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I am trying to adjust colors after I apply a 3D effect (say extrude & bevel) in Adobe Illustrator (I tried in CS2 and CS5) but even if I make the object's color white it turns into fairly dark gray after the effect; I cannot make it lighter. I tried to play with shading but no luck.

I understand there should be shading and color change to show the 3D effect but the change is quite extreme.

Can anybody give me suggestions on how to preserve the colors with 3D effect in Illustrator?

share|improve this question

5 Answers 5

I've had the same problem, along with Scott's answer, changing stroke colour made the most significant difference.

Changing the fill, stroke and custom colour (in 3D Extrude and Bevel Options) of the object to the same colour; will remove all shading, and make any changes to the lighting options ineffectual.

Hope this helps anyone with the same problem.

share|improve this answer

I don't know if you're still dealing with this, but in case you are anyone else could use the help.

I've found adjusting where the light is hitting the object to be of a big help. In the additional options panel (in the above picture) there is a graphic toward the lower left. The large ball represents your object and the white dot represents the light. Click-drag that dot, the highlight center, to your desired location. There is another dot, black by default, that represents your shadows. Adjusting these in multiple combinations as well as ambient light will allow you to brighten, darken, smooth out, and add contrast to your lighting situation.

Hope it helps. I've actually run into another problem where the first character of my text won't display gradient color when the rest of the text will.

Anywho; good luck!

share|improve this answer

Change the shading color to something lighter than Black (the default)

3D Effect

share|improve this answer
    
Well, I have tried that too and it helped a little but the object is still dark. I guess this is how it is, I tried playing with all the parameters in that screen and I still cannot get the a color close to the one before the effect. –  Engin Feb 11 '13 at 20:07
1  
@EnginYapici If you don't want color changes, select No Shading from the Surface drop down menu. –  Scott Feb 12 '13 at 2:56

You might be working in CMYK mode or have transferred the object from an RGB file to CMYK.

share|improve this answer
    
Nope, I work in RGB mode and I created the object myself, didn't import it. –  Engin Feb 11 '13 at 20:09

Go to Effects >> 3D Extrude & Bevel click on More Options(you can find below Map Art) Reduce Light Intensity value, make Blend Steps 1 or 2 (adjust the value).

share|improve this answer
    
I tried those, colors are still very dark. I changed ambient light and made the colors lighter but I cannot change it much because object loses its 3D effect after a certain value. –  Engin Feb 11 '13 at 5:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.