Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I've had this issue with Photoshop where some dark blues are displayed in black on Photoshop if I'm in RGB mode and selecting dedicated graphics in the performance preferences. If I don't select dedicated graphics or change to CMYK the issue gets fixed although I would like to be able to work in RGB mode and have the dedicated graphics on. What can I do?

share|improve this question
    
I have a similar issue. I recently brought a new computer with Windows 8. I upgraded to Photoshop CS6 64-bit, and ever since I have had display issues. I get flashes and the Photoshop workspace turns to black when I am working. Colors display as if they were out of gamut or posterized as you describe (appearing as black over areas of the image). One thing I did find out was that by upgrading to the latest beta driver for Photoshop that the flashing and blacking of the workspace improves, though the problem persists. You might want to try this. –  Sophia A Feb 26 '13 at 14:22
    
probably yes, but did you update your video cards's drivers to the most recent versions? –  Bakabaka Feb 26 '13 at 14:27
    
I also have similar issue, on my Windows 7. Some cyan-like colors will be displayed as black. When I drag the window of the photo around, strange enough, the cyan can be displayed normally while dragging! What problem is it likely to be?? –  user12942 May 24 '13 at 7:56
add comment

2 Answers

Try disabling the 30 bit display checkbox.

My cyan color looks normal again without blacky color, without sacrificing advanced GPU mode.

share|improve this answer
add comment

You may want to read the Q&A in this link I just found. From that page:

Looks like a problem with your display calibration. It could be the display profile, or it could be a bug in your video card driver (the shaders used to perform color correction).

Try setting the Photoshop GPU mode to "Basic", then relaunching Photoshop. If that solves it, then the cause was the shaders (and a bug in the driver). If that doesn't solve it, then the problem is most likely your display profile.

share|improve this answer
1  
I do recommend this solution. –  Viswalinga Surya S Aug 2 '13 at 12:40
add comment

protected by Scott Dec 26 '13 at 20:05

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.