Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

This question already has an answer here:

When I create a new document, this option is available, but how to disable it, when the document is already created?

  1. I can select shapes and disable it via the transform panel but not for newly created shapes.

  2. When selecting symbol this option is greyed out, Illustrator realigns the paths anyway.

share|improve this question

marked as duplicate by JohnB Sep 3 '13 at 14:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers 3

up vote 5 down vote accepted
  1. In the top right corner fly out menu of the transform panel, you can select or deselect "Align New Objects To Pixel Grid" globally for all future objects/paths (see below image)

  2. For each already created path/object use the checkbox in the transform panel itself

  3. The paths within the symbol might be set to "Align To Pixel Grid". Disabling it for the specific paths might be ignored anyway, so it's necessary to dispatch the shape from the symbol, disable the align option and recreate the symbol. Illustrator bugginess FTW.

transform panel

share|improve this answer
    
can I do this since the document is already created? Or should I start over new document? Also where in the preferences this can be disabled? –  Vladyn Jun 10 '13 at 10:42
    
@Vladyn yes, as I wrote already: in the transform panel, disable "Align To Pixel Grid" globally for all future objects/paths in the fly out menu (d.pr/i/QFMH) but you need to disable it for each already created object/path individually in the panel itself. –  owzim Jun 10 '13 at 11:52

you're probably best to do this when setting up a new document in the document set up dialogue box. i think you can also turn it off in the preferences which would be a good idea because in my experience it does nothing but cause trouble!

share|improve this answer
    
Sure but the question aims specifically at how to disable it when the document is already created. –  owzim Jun 10 '13 at 11:55

I had the same problem... using pathfinder and shapes got distorted even when previously expanded.

Solved the problem by:

  1. Creating a new document
  2. On the first document setup panel, click "Advanced"
  3. Then unclick the "align new objects to pixel grid" box.

Works perfect, and Illustrator is back.

cheers

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.