Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

Here's the task: I import an image, trace it black and white, and then try to convert the result into a compound path in order to use it easily later on.

Here's the problem: When I combine to a compound path, nothing shows up - either it appears as completely white or completely black. All the vectors forming the object are still there, but the result is blank.

Here's why: When I trace the object, it creates duplicate lines. Each line that appears in the result is actually two lines on top each other - even when ignoring white. In the result, the first set of lines wrap the actual object fill areas. The second set of lines either wraps all the white sections (if not ignoring white), or wraps nothing, and acts as just lines. When converted to a compound path, fill-content is ignored. Since vector shapes in compound paths invert when intersecting, everything fills together, making everything appear one solid black rectangle (or nothing at all if there's another line-vector wrapping the border).

Here's the question: How can this be avoided when tracing? Or, perhaps, how can I remove all the empty lines before combining to a compound path?

share|improve this question
1  
Usually you should not answer your own question in the question. Just make a self-answer, that is wellcome here to keep questions and answeres divided ... –  Kurt Apr 9 '13 at 22:28
    
Well, ya - I would if I had enough "reputation". I couldn't separate it within the first 8 hours. –  AUTO Apr 11 '13 at 1:04
    
I'm sure you will soon have the reputation to do it ;-) The other thing in my eye is that Scott already gave the same answer. Who was first? –  Kurt Apr 11 '13 at 1:12
    
I separated it. And I actually answered it first. I kinda figured it out as I was asking the question, but I still put it up since I figured it could help others with the same problem - plus in case I could get a better answer. p.s. What do you mean the same answer? –  AUTO Apr 11 '13 at 15:23
    
Great, thanks! Well, for me the answer of @scott looks well ... (but I'm not an expert on this). –  Kurt Apr 11 '13 at 15:27
add comment

3 Answers

Here is a great way to manipulate lines in Illustrator and may help answer his question. 1. select all 2. select sketch in image trace (sketch works the best) 3. open window/image trace palette 4. select various options by watching more in depth in this video I found: https://www.video2brain.com/en/lessons/converting-art-to-vector-with-image-trace 5. This allowed me to increase the threshold to 180 and picked up all my lines. You can reduce noise to about 10%. 6. Lastly, you can use the eraser tool in outline mode and not see any of those crazy lines you saw before. 7. I struggled all night and found this video and this enabled me to have my object fully outlined perfectly and edit it.

Hope this is of help!

share|improve this answer
add comment
up vote 2 down vote accepted

Well, I just figured it out - so for those who might wonder, here's an answer.

  • Trace the object without ignoring white.
  • Use the magic wand tool to select all the white areas.
  • Then delete them.
  • Then combine to a compound path.

Because all the white areas are gone, they won't become black when combined (since varying fill-style is ignored when combined to a compound path). For more details, read the why in the question.

Although there might be other ways, this works for me.

share|improve this answer
add comment

Image Trace. Ignoring white or not doesn't really matter other than if you want white or not. The steps below work with or without white.

  • Expand the trace and Pathfinder > Merge. This removes the superfluous objects.

  • Sometimes it's also helpful to draw a no-fill, no-stroke rectangle and choose Select > Same > Fill & Stroke then hit delete.

The merge step will automatically create compound shapes. There's no need for you to do it manually.

share|improve this answer
    
I'd perhaps accept your answer if I could get it to work, but I've tried it over and over again, and "pathfinder > merge" is not doing anything. When you say that, do you mean "effects > pathfinder > merge"? Keep in mind, I am using cs6. –  AUTO Apr 11 '13 at 1:19
    
No, just the merge button on the Pathfinder Panel. Works every time for me. –  Scott Apr 11 '13 at 1:41
    
Oh the panel - I just tried it but it still doesn't seem to merge it to a compound path. Note I want to merge everything from the expansion to a single compound path. –  AUTO Apr 11 '13 at 15:31
    
works here. Not sure why you don't get similar results. –  Scott Apr 11 '13 at 16:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.