Sign up ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

By default when sampling colors in Photoshop with the eyedropper the color selected shows up as the foreground color, currently when i try sampling a color it sets it as the background color -how can i fix this error? (any clues how this change occurred?)

share|improve this question
Is your Alt or Option key stuck? If not, reset the preferences. – SOIA Apr 19 '13 at 17:17
@Scott no everything is the way it should be-that was the first think i checked when this behavior started – Pastel Apr 19 '13 at 17:35
@Scott I am reluctant to reset all preferences & thats why im asking this question – Pastel Apr 19 '13 at 17:36
Well, there's no substitute for resetting prefs. If something isn't operating as expected that's the first line of troubleshooting. You can always move preferences files and restart the app to see if that corrects the issue. – SOIA Apr 19 '13 at 20:25

2 Answers 2

up vote 5 down vote accepted

You need to left-click on Foreground colour swatch in your Color panel. The tricky part is to determine if Foreground or Background colour swatch is selected.

This is probably what you have now:

Background colour swatch selected Background colour swatch selected (magnified)

And this is how it should look like:

Foreground colour swatch selected Foreground colour swatch selected (magnified)

share|improve this answer

I'm on a Mac with the latest CC. When using another tool and holding down the option key, my color picker assigns the selected color to the background. I don't know what "left click" produces, but I don't get this outline around the fore or background color picking icon.

share|improve this answer
I guess this should be better an comment than an answer? Or is this a following up question? For a new question please ask a new question. If that should be an answer please make clear by edditing it is an answer or not that it should be a comment. A moderator can chnage your answer to an comment then. – Kurt 16 hours ago

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.