Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I'm working on some print design in Adobe Illustrator, but I can't seem to figure out this one thing. It's probably stupid, but would really appreciate if someone could help me out.

I've create a modified a circle - shape, which has a number of anchor. When I fill it, I need there to be a circle in the center which would allow that center to be see through and reflect the design of the background. But when I use the pathfinder I get a weird output which I assume is due to the anchor points in the back image. ![enter image description here][1] Please help!

I figured this wouldn't be too clear in writing so I have made a video with my problem! http://youtu.be/-urNULSH7GE

This is urgent, thank you to anyone who can answer this!

share|improve this question

migrated from stackoverflow.com Apr 27 '13 at 12:26

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 0 down vote accepted

You've got an effect applied to the outer shape to create the ridges/bumps. Effects alter both outer and inner paths. You can not tell an effect to only alter the outer edge of a compound shape. Therefore when you create the compound shape via Pathfinder, the effect is causing the same ridges on the inner path which results in the unexpected shape you are seeing.

Simply select the outer shape and choose Object > Expand Appearance to remove the live aspect of the effect. Then, pathfinder will operate as you expect. You will not be able to alter the ridges in a live manner after this.

effects

share|improve this answer

It's a big hard to say without having the actual .ai file but a few things that could be happening are:

  • In the pathfinder window, sometimes you need to click on the "expand option" to be able to have the image cropped/merged/ properly

  • Perhaps you are using the wrong function or is not at the front/back as it should be. Make sure you are using the minus front option and the circle is 100% at the front

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.