Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have a shape in Photoshop with some layer effects. When I go to convert that shape to a smart object, the drop shadow darkens. Prior to converting, the shape has a normal blend mode with opacity and fill set to 100%. Is there some way to convert the shape and keep the same drop shadow?

Here is an image of what is happening. This also happens when I save the image as a png.

http://imgur.com/W7jkS4q

share|improve this question
    
Are you viewing the image at 100% before and after smart object conversion? Unless you view at 100% you can't be certain how things look. –  Scott May 8 '13 at 16:12
    
Yes I am viewing at 100%. The same thing also happens if I save the image as a png. –  user715564 May 8 '13 at 16:17
    
I updated the question with an image that shows what is happening. –  user715564 May 8 '13 at 16:19
    
You're using a color or linear burn blend mode for the shadow, right? –  Scott May 8 '13 at 16:24
    
Wait..yes that's it. The blend mode for the actual drop shadow is set to overlay. –  user715564 May 8 '13 at 16:26

1 Answer 1

up vote 3 down vote accepted

Smart objects are self-contained. They are treated as a single layer within the parent Photoshop file. Internal blend modes over transparency will have no effect on other non-smart object layers.

To solve this issue, remove the 'overlay' drop shadow from the internal smart object layer (just turn off the visibility) and apply the 'overlay' mode drop shadow to the smart object itself.

smart object modes

This may alter how you think about construction and what you place into a smart object.

Simply put, some blend modes won't work unless they have additional layers to interact with. Because smart objects are containers, internal blend options only interact with items within their own internal container.

share|improve this answer
    
"Simply put, some blend modes won't work unless they have additional layers to interact with. Because smart objects are containers, they only interact with items within their own container." Ok, yeah that is the problem. It looks like I am going to have to redo a lot of stuff with this one. Thanks for the help. –  user715564 May 8 '13 at 16:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.