Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I found a similar thread that gave some great pointers, but still doesn't solve my issue.

My boss asked me to create a corporate presentation, and I had the unfortunate idea of doing it all in photoshop (I figured it would allow greater flexibility than the usual powerpoint).

I created 24 slides at 3000x2000px and 300dpi, for a total size of 69Mb.

Now obviously this is not ok for a presentation that must be sent via email to multiple clients, so i decided to reduce its size using the technique described in the thread above.

Before:

https://dl.dropboxusercontent.com/u/93652605/before.png

After:

https://dl.dropboxusercontent.com/u/93652605/after.png

It all worked great and the file size is now down to 4Mb, only problem is that the text is starting to blur. Since it appears that text makes up for only about 3% of the total file size (it's the images that are bloating up the Mb count), I was wondering if it's possible to reduce the image quality without "touching" the text layers.

In powerpoint you can have a bad quality background image and write perfectly sharp text on in. Even at 640x480 text looks good in powerpoint. On the contrary, if I lower the res in photoshop, the text turns crappy.

So is there a way to add hi res text to a low res "background" image in photoshop?


UPDATE: after a long afternoon of work, and thanks to John's help, my presentation is now perfect, so I thought I'd give back to the community an share a couple more things I've learned working on this project.

This is what the text looks like after the PDF conversion when faux styles is applied PDF with faux and this is what it looks like when you strip off all styles from it PDF no faux.

As you can see, like John said, if you have faux styles applied, the text is automatically rasterized and this creates a lot of artifacts during the conversion. On the contrary, if there are no faux styles, the text stays in its vector form and, even when you reduce the image quality a lot (see the picture on the right side of the image), the characters remain tack sharp.

So I went ahead and re-formatted all the text boxes in my presentation. Again something went wrong see here. As you can see, sometimes the PDF version screws up your text. As silly as this may sound, I found that this only happens when you write too much text in a single box. All text longer than 6 or 7 lines got screwed up. Splitting it into two different text boxes with 3 lines each fixed this. The same problem happened on multiple slides, and the same solution worked to correct the problem on all of them.

Last but not least, I managed to decrease the total file size some more by going to file->Automate->PDF presentation (not sure about the exact translation cause my photoshop is in italian) instead of the usual file->Save As->Photoshop PDF. Try for yourself, with the same compression values the first option yields smaller files (some 30-50% smaller!!). So I guess there's some hidden parameter that the "Automate" command sets somewhere that the "Save As" does not.

I now have a 2,8Mb presentation with razor sharp text and low-res images (still looking good ad 100% zoom, artifacts start showing only at 120%). Thank you stackexchange! :)

share|improve this question
2  
Have you by any chance rasterized the text? –  Joonas May 21 '13 at 11:35
    
Not that I know of. I just went to image->image size and resized to 25% original size while mantaining 300dpi of res. Text layers still appear as text layers (i.e. editable) after resizing, but now the font is all grainy and ugly... –  Bruder May 21 '13 at 11:44
1  
Have you tired exporting them as PDF so that the text remains vector and any images get compressed? –  JohnB May 21 '13 at 12:32
    
@JohnB If I save them as photoshop PDF the file size bloats. A 2.5Mb psd image became a 21Mb pdf file. I clicked the "optimize for web" option but it didn't really help :( –  Bruder May 21 '13 at 12:40
    
What about the compression settings in the Save Adobe PDF dialog? Did you try dialing it way down? I can get my 1.11MB test document down to 52.9KB with the right settings –  JohnB May 21 '13 at 12:44

2 Answers 2

up vote 5 down vote accepted

For something like this with lots of text, you can greatly reduce the file size of a PDF saved in Photoshop by making sure that the text is exported as vector.

The reason your text is not being exported as vector is because you've got some of Photoshop's "Faux Styles" applied to your text. Any time you have one of these (Faux Bold, Faux Italic, Small Caps), the text will get rasterized in the PDF.

Faux Styles

Avoid these whenever possible. Use a heavier weight font from the same family if it exists.

Unfortunately for you this means you'll have to do a lot of re-formatting; it's up to you to decide if the filesize vs. quality is worth the commitment of time

share|improve this answer
    
I really wish I knew that earlier =D Anyway, it works like a charm, by eliminating faux formatting I can save as PDF straight from within photoshop and with a "Medium" compression I can get 200Kb files with little artifacts on images and tack sharp text. Thanks John! –  Bruder May 21 '13 at 14:17

First of all You should try reducing from 300dpi to 72dpi .

Remove faux style's and try saving it in PNG format.PNG format is good for this type of pictures.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.