Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

When I create cross-references to other documents, InDesign gets very slow accessing to disk all the time (I can see the Windows icon) unless I open all related documents.

Is there a way to deactivate this behavior within InDesign?

I am using Indesign CS4 on Windows 7.

share|improve this question

3 Answers 3

In order to set up a cross-reference, InDesign has to ensure that it has the target page correctly identified. To do that, it has to know exactly what the page count of the book is. If the intervening chapter files are closed, InDesign can't be sure their page counts haven't changed, so it has to open them in sequence, check their page counts and update them if necessary, then close them. All that disk overhead adds up fast if you're not working from a solid state drive.

Keeping all documents and the book file open while working on long documents is a best practice, especially when you start adding cross-references or other internal hyperlinks. It allows InDesign to work at full speed without unnecessary disk i/o. It also allows the program to track changes in page count and page numbering so they update along with any cross-references and internal links in real time, makes synching styles much faster, and is an easier and more reliable way to work.

If your system is too short of memory to work efficiently with multiple documents open, add some RAM. It will pay for itself many times over in saved time, not to mention helping your hard drives last longer.

share|improve this answer

Sadly, the simple answer is no. There is no option to simply pause syncing.

So really your only two options:

  1. Keep all of your referenced files open while you're working.
  2. Keep your referenced files on an external drive that can easily be un-mounted. then when you're ready to update the cross references just mount the drive and they should update automatically.
share|improve this answer

Have you tried changing similar settings to the screenshot attached? I found these from Edit > Preferences > File Handling. Admittedly I'm using CC version so maybe labelled differently.

File Handling settings

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.