Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

I have an image which has a layer mask so that the image fades to transparent. However when I try to export the image (Save for Web) as a PNG the layer mask is lost. What am I doing wrong? Can this be done?

Cheers

share|improve this question
1  
Are you sure you don't have something like Background layer still in the document? –  Joonas Jun 10 '13 at 15:06
    
Reset your Photoshop preferences and ensure you don't have a matte color selected in save for web. –  Scott Jun 10 '13 at 23:04
    
Either there's a bg underneath your layer, or the transparency option isn't checked when you're saving for web. As someone else mentioned, make sure it's png 24 and not 8. 8 has transparency as well, but it's low enough quality that it's basically never worth it. –  Eric Jul 11 '13 at 21:00
add comment

1 Answer

Make sure you have it set to PNG-24, not PNG-8. Also confirm that the Transparency option is ticked and it should work fine.

share|improve this answer
    
Thanks, that's what I thought, however it doesn't seem to work! –  nicklx Jun 10 '13 at 15:02
    
In your save for web pop-up, can you see the transparent squares in the background of your image? –  John Jun 10 '13 at 15:07
    
Input Image Output Image –  nicklx Jun 10 '13 at 15:17
    
I really don't know the cause, but just to help you trouble shoot, when you click the preview button at the bottom of the save for web dialog, it gives you a preview in the browser. Does that say 'Transparency on' in the settings summary on the browser page? –  John Jun 10 '13 at 15:40
    
It does indeed. However the image still doesn't look right... Thanks anyway. –  nicklx Jun 10 '13 at 15:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.