Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have text in 2 columns in a text box. There are large gaps inbetween some of the words in one area of a column. There is one space before and after each word. What could account or this?

share|improve this question

1 Answer 1

The mostly likely reason is that your paragraph style (or the paragraphs with the problem) have Justify turned on and Hyphenation turned off. It's usually not a good idea to justify text when the width of the column is small relative to the size of the text. A good rule of thumb, if you don't want too many hyphens, is 55-60 characters per line. Sometimes you can get away with less, but most typesetters err on the conservative side.

Why the gaps? By default, InDesign adjusts only word spaces to justify text (in common with most other programs), but it has options that can help get rid of the uglies. Here is the dialog (Ctl-Alt-Shift-J/Cmd-Opt-Shift-J is the shortcut). I'm using InDesign CC, but the options haven't changed since at least InDesign 2.0:

Default justification dialog

And here is some text set in a narrow column (30-35 characters) with that default:

enter image description here

Ugly, indeed. I don't know any text designers who like the defaults under any circumstances, but the problems are pretty obvious here.

My own preference is to reduce the allowable word gap and allow InDesign to adjust letter spacing. (If you're using a serif font, glyph scaling can also help, but use cautiously and avoid using it with a sans.) My preferred settings for Minion in this kind of situation are usually in this range:

Modified justification settings

And here is what that same text looks like now:

Text with justification settings

The difference is obvious. With any given passage of text, you might need slightly different settings, and in some cases the word breaks are so bad that InDesign has no choice but to stretch things beyond your limits. You can have InDesign highlight these by turning on "H&J Violations" in the Composition settings in Preferences.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.