Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

If I'm working on a document in Photoshop and I want to drop in an image by dragging the file from Windows explorer into the open Photoshop document, I can do that. It inserts the dropped image in a sort of "placement" mode until I finalize by pressing 'Enter'.

The problem is, it doesn't insert the image at the image's actual size. It's generally smaller. Sure I can scale it once after dropping it in but that's not very accurate. In order to get the image to go into the document at its correct size I first have to open it in Photoshop as its own document (for example, dropping it into an empty area of the Photoshop window), and then drag that as a layer into the document I'm working on. This feels more like a workaround than a solution/answer.

How can I drop in an image file into an open Photoshop document without it inserting it into the document at the incorrect size?

share|improve this question
    
Thanks, but that's still more work than my workaround, which simply dragging it into Photoshop and then dragging it into the document. My method is two steps. I was hoping for a one-step method that didn't alter the size. –  vertigoelectric Jun 21 '13 at 6:47

3 Answers 3

This is because of the difference in PPI between the image you are placing and the PPI of your document.

Here I've placed a 350 PPI image on a 72 PPI document:

Example PPI placement mismatch

But if I place the same image on a 350 PPI document (same pixel dimensions, compare the rulers of each document):

Example correct PPI placement

How you can fix this:

You can edit the PPI of your image. This is stored in the EXIF data. You can use a program like IrfanView (under Resolution in the Image Properties)

IrfanView Screenshot

This method is probably more of a pain than it would be to open up the image in Photoshop then copy and paste it into your document, but I was not able to find a way to prevent Photoshop from behaving this way (perhaps someone else will prove me wrong!)


Image Credit: Jens Wilmer

share|improve this answer
    
I appreciate your efforts but that is definitely more work than it's worth, especially when it's much easier to just drop it into Photoshop as its own document and then moving it as a layer to the document I want to put it in. It's really not even that big of a deal, but it does seem unnecessary. Although it makes me wonder, if it's a DPI issue, then why does the 'workaround' I mentioned work? –  vertigoelectric Jun 20 '13 at 4:48
    
@vertigoelectric I'd only be guessing at this point, by my speculation would be that the clipboard does not store any PPI information so Photoshop has no choice but to place the image pixel-for-pixel –  JohnB Jun 20 '13 at 10:10
    
Except I'm not using the clipboard. I'm not copying and pasting. I'm just dragging and dropping. I drop the file into Photoshop so it opens as its own document. I then drag it from that document to my intended target document and drop it. –  vertigoelectric Jun 20 '13 at 14:21
    
@vertigoelectric whoops, I misread your workaround (my method is always to copy and paste). Really, I can't give you an accurate answer to that. I would still assume that the principle is the same, though: PPI information isn't transferred when dragging layers from one document to another. –  JohnB Jun 20 '13 at 14:54

I think I found an answer to

"How can I drop in an image file into an open Photoshop document without it inserting it into the document at the incorrect size?"

Turn the following options OFF:

Edit > Preferences > General

I recognize that this question is a couple years old, but if anyone else found that this worked for them, let me know (I did a few tweaks but I think this is the one that made it work for me)

share|improve this answer
    
I appreciate your answer, however I already have these options turned off and it still inserts it at the incorrect size. –  vertigoelectric Jun 2 at 4:18
    
Thanks! I had the same problem in CS5. Updating my preferences to the settings listed above totally helped! Thanks again! –  Kristina Laude yesterday

To resolve this issue, I did the following: Edit> image size Select "Resample": Preserve Details

change "Resolution:" to 72 for both images ( I used 72, but as long as both images are the same here it should be fine)

hope this can help

...also, under view, I select "print size" to see the actual onscreen size (for this to work, make sure Edit > Preferences > Units & Rulers has the correct Screen Resolution for your screen (PPI based on horizontal pixels, vertical pixels and diagonal size of your screen...lookup Display PPI Calculator to figure it out)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.