Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have a PDF document with text created from a Photoshop file.

Problem:
When I do "select all text" in Acrobat and then copy-paste it into a text editor the text is pasted out of order.

This is somewhat expectable because of the multiple text layers in the original Photoshop file.

Question:
How can I tell Photoshop the desired order of the text layers when creating the PDF file?

The layers are stacked in the correct order in the layer panel in Photoshop. I was hoping that was the issue, but it's not. Is there any other way in which I can specify the text order?

share|improve this question
2  
Why are you using this workflow? Does Acrobat > File > Save As > More Options > Text result in a better text file? –  Scott Jun 23 '13 at 7:22
    
The final product needs to be a PDF document, in order to show the structure and illustrations. But this PDF file needs to allow the user the option to copy all the text and edit it in a text editor. –  Nelu Malancea Jun 23 '13 at 18:35

1 Answer 1

up vote 1 down vote accepted

Turns out the order of the copied text in the PDF is the same as the order in which the text layers were created in Photoshop.

Solution:

  1. Create a copy of the Photoshop file.
  2. Delete the text layers from the new file.
  3. Copy the text layers one by one from the old file into the new file, in the correct order.

Now if you export to PDF and copy the text from there it will appear in the correct order on the clipboard.

share|improve this answer
    
Could you not simply reorder the text layers in the layers panel within Photoshop? I believe, and I may be wrong, that they are written "top down" when looking at the layer stack. –  Scott Sep 3 at 18:25
    
As I mentioned in the question, the layers are in the desired order in the layer stack. For some reason when the PDF is generated, the text gets ordered by "time created" of the text layers, not by the layer stack order. I hope Adobe has fixed this issue by now, but I spent days trying to figure it out. –  Nelu Malancea Sep 3 at 19:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.