Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have an Illustrator file that's behaving strangely when I print it to PDF. Basically, it adds small lines around shapes; I included a zoomed-in screenshot. enter image description here

If I save the file as PDF, the lines don't appear but then the file itself is huge: 30MB. Has anyone seen this issue and if so, how do you solve it?

Thanks.

share|improve this question
    
Looks to be outlines of your drop shadow effect. It's been a while since I've used Illustrator, but is there a way to rasterize a copy of that layer? If there is, try that and hide your original layer to see if it shows up still. –  ckpepper02 Jun 27 '13 at 20:36
    
Well I'm looking to keep everything in vector format. –  frenchie Jun 27 '13 at 20:50
    
Everything there is not vector.. which is why you get the anti-aliasing edges. See my answer. –  Scott Jun 27 '13 at 21:01

1 Answer 1

up vote 5 down vote accepted

These hairlines are due to flattening in the PDF.

Since the file is being flattened, I'll assume you are printing to a PDF/X-1a or PDF 1.3 (Acrobat 4) format. These formats are flat file formats. They don't hold transparency so when you export/print to these formats all the transparency effects must be flattened so the file will print correctly.

The hairlines are primarily an on-screen issue. You'll notice that when you zoom in and out, while viewing the PDF, the lines will move or vanish at one zoom level and reappear at a different zoom level, but they will never increase in size. These are anti-aliasing edges showing between blocks of raster images which were necessary for the PDF engine to create in order to maintain the file appearance in a flat format.

The hairlines should vanish when the PDF is printed.

If they really bother you, then you'll need to either flatten transparency before creating the PDF (why are you printing to PDF rather than merely saving?), or Save as PDF 1.4 (Acrobat 5) or PDF/x-4 so that the PDF format will support the transparency rather than flattening it.

share|improve this answer
    
It's amazing how often this question comes up. It scares the crap out of clients every so often. To vanish it for on-screen viewing, turn off "Smooth Line Art" in Preferences/Page Display (uncheck "Use 2D graphics acceleration" first if it's checked, to make the "Smooth line art" checkbox available). –  Alan Gilbertson Jun 28 '13 at 21:56
    
@AlanGilbertson Excellent point. I think the majority of the issue may be that the Smooth Line Art option is on by default -- same annoyance as the Overprint Preview being off by default. I wish Adobe would alter the defaults. –  Scott Jun 28 '13 at 22:49
    
Indeed. And that suggestion's been made often enough over the years, but the Acrobat team seem to largely ignore the needs of graphic designers. They are very focused on enterprise document handling, since that's their primary customer base. –  Alan Gilbertson Jun 28 '13 at 23:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.