Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have imported a set of PNG'S as layers by calling FILE > OPEN AS LAYERS

And I get the result:

Screenshot of GIMP

All the layers are oddly cascaded on top of each other

So when I got to export it, I get this:

enter image description here

What I want is to get each frame showing by themselves, what am I missing?

Can anyone help me with a solution?

Thanks in advance.

Chris

share|improve this question

1 Answer 1

up vote 2 down vote accepted

When you export a multi-layer image as a GIF animation, you should get a dialog window asking you for various settings. One of those settings is "Frame disposal where unspecified", and the options are:

  • "I don't care",
  • "Cumulative Layers (combine)" and
  • "One frame per layer (replace)".

I'm not actually sure what the difference between the first two options is, but the one you want to select is the last one: "One frame per layer (replace)". In this mode, each frame of the animation will be erased before the next one is drawn.

As the title of the setting hints, it's also possible to control this behavior on a per-frame basis. The trick is to simply include the text (combine) or (replace), including the parentheses, in the name of the layer.

You can also specify the amount of time the frame will be displayed the same way, by including a string like (100ms) in the parentheses, replacing the 100 with the desired time in milliseconds. Note that, even though GIMP lets you specify the delay down to a millisecond, the GIF format rounds it to the nearest 10 ms. Also, frame delays of less than 60 ms are inconsistently supported in different viewers, and should generally not be used.

share|improve this answer
    
Absolutely brilliant answer, thank you so much :) reputation++; I actually looked at those options, and didn't realise the functionality of that checkbox. Ta! –  Chris Aug 16 '13 at 9:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.