Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

When I have a large smart object, and then shrink it down, I often get some extreme sharpening. And while I understand that shrinking down an image may require some sharpening, photoshop can go a little overboard.

Here, for example, is a large 1:1 smart object on the right and the result when shrunk down on the left.

enter image description here

It also happens in Save For Web output:

enter image description here

How can I control this sharpening and still maintain the Smart Object link?

share|improve this question
1  
Is the sharpening an issue upon output? It may just be a rendering issue with Smart Objects which is corrected upon output. –  Scott Aug 16 '13 at 1:24
    
@Scott Save For Web exports with this exaggerated sharpening, which is the most import output channel to me. So it's not just this way in the photoshop viewport, but in 24 bit PNGs I generate for web use as well. –  Alex Wayne Aug 16 '13 at 1:29
    
How much reduction are you introducing? Is it less of an issue if you size the original artwork closer to the output size within the Smart Object? I'm guessing it's a vector SO and it's the anti-aliasing of vector paths causing this. I'm not seeing any such sharpening with vector Smart Objects here, but you may naturally work at much larger sizes. –  Scott Aug 16 '13 at 1:34
1  
I'm not sure what is happening in the first example but in the Save for Web Preview you are viewing at 1600% - anything will look bad scaled up that high even big Smart Objects because you are scaling the document and not the smart object or vector. The document still has a fixed resolution. –  deecemobile Aug 16 '13 at 19:09
1  
(Response to last comment from Alex Wayne) I'm not objecting to the pixelation, just the sharpening effect that gets stronger the more you shrink it. Notice the bright pixel that appear on the edge of the skin tone that are not present on the original art. Even at 1:1 this sharpening can be quite noticeable and undesired. – Alex Wayne –  Yisela Aug 16 '13 at 23:25
show 3 more comments

2 Answers 2

up vote 1 down vote accepted

The problem is: Bicubic resampling.

I think you need nearest neighbor resampling (In the save for the web window you can select it under "Quality") For more information: http://www.earthboundlight.com/phototips/resizing-resampling-photoshop.html

Update: For smart objects there is no resampling option :( : http://forums.adobe.com/thread/1026169

share|improve this answer
    
Doh. Well, thanks Adobe... I guess the answer is: Don't use smart objects if you want control over resampling. Which pretty much sucks... –  Alex Wayne Aug 21 '13 at 17:22
add comment

Actually you CAN reduce sharpening of scaled down smart objects. It's a bit tricky though. You have to change interpolation method. Go to Edit > Preferences > General and change Image Interpolation as desired. Than select your smart object and hit Ctrl + T (for Windows), than without any transformations hit Enter to apply. Your object will stay intact, only its interpolation method will change (refresh). So to make it not so crispy sharp change interpolation to Bicubic or even to Bicubic Smoother.

Note that this trick works only for one smart object at a time, if you select multiple smart objects and transform them all together they don't refresh (interpolation wise), so you have to transform multiple smart objects one by one.

Cheers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.