Sign up ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I'm having some trouble resizing a group of vector objects in an illustration. These objects used to be lines until I expanded them into vector shapes, and before I scale them they look fine:

image 1

But as soon as I scale them the width of these "lines" completely distort:

image 2

These are the possible solutions I've already tried, but hasn't had any effect:

  • Checking align to pixel grid

  • Scaling after grouping objects

  • checking scale strokes & effects

If anyone has any idea what might be causing this, any help would be appreciated!

EDIT: Included a download link to my file if anyone's interested:

Get the .ai here

share|improve this question
Did you select the objects when checking Align to Pixel Grid? Things have to be selected first. – SOIA Aug 22 '13 at 8:20
Good point, but unfortunately yes i had selected the objects already. It doesn't seem to make any difference wether i got that checked or not. – bestfriendsforever Aug 22 '13 at 8:27
If the lines are selected, what does the Appearance Panel look like? – SOIA Aug 22 '13 at 8:29
Doesn't look unusual, No Stroke, Fill white, Opacity default. its just a standard vector shape. – bestfriendsforever Aug 22 '13 at 8:37
Although in the dropdown menu "New Art Has Basic Appearance" has been checked (no idea what that means). Tried unchecking it and then resizing, same results. – bestfriendsforever Aug 22 '13 at 8:40

3 Answers 3

up vote 8 down vote accepted


Align to Pixel Grid is indeed checked in your file. Actually it is hyphenated indicating some objects are set to align to the pixel grid and some objects are not. Select all and then uncheck it on the Transform panel. If you don't see it on the Transform Panel, click the menu icon on the Transform Panel and choose "Show Options". You will then have to click the Align to Pixel Grid checkbox twice. Once to check it - removing the hyphen, then again to uncheck it. This will correct the issue with art being changed upon scaling.

In addition....

Looking at the file in Outline mode (View > Outline) shows areas of misalignment in the shapes. When you scale these areas of misalignment the inconsistencies in construction are merely easier to see.


This is caused by expanding overlapping shapes which don't line up precisely.

You can reduce many of these areas by locking the blue background, selecting the white areas and using the Merge button on the Pathfinder Panel (not the Pathfinder Effect menu item) to create solid shapes rather than overlapping pieces.

  • Select the Blue
  • Choose Object > Lock from the menu
  • Select one white shape
  • Choose Select > Same > Fill & Stroke from the menu
  • Click the Merge button on the Pathfinder Panel (Window > Pathfinder - DO NOT use the menu item.)

After doing this the art will appear much less complex in Outline mode. However, there will be areas which have issues due to the uneven expanded strokes...


These areas will have to be fixed manually.

share|improve this answer
You absolute genius! I was confused about what you meant about the hyphen first but i realised that I hadn't checked "Show Options" in the dropdown box, and there it was! That using that checkbox is a lot better than using the tick in the dropdown menu it seems. Also thanks for the tips on how to refine my hurriedly put together shapes, very much appreciated! – bestfriendsforever Aug 22 '13 at 9:22
Glad I could help. – SOIA Aug 22 '13 at 9:25
What an aggravating setting. Thank you so much! – b.kelley Feb 10 at 15:21

I had the same problem and as of now you have to start off with "Align New Objects to Pixel Grid" turned off BEFORE you create any object (at least for me), because turning it off after still gave me errors, I'm hoping it's a glitch they will fix.

Let me rephrase, it seems to work if you uncheck when the Options panel is visible, but not by checking it off using the pull down menu!

share|improve this answer
Yes thats worth pointing out. create your objects after unchecking that checkbox. – bestfriendsforever Nov 11 '14 at 15:16

I had the same problem. I used Object > Flatten Transparency (with the art selected) and it fixed it.

Why? I have no idea but it did work, even though there was no transparency applied to the art that I know of.

share|improve this answer
That worked for me. :D I don't know why but everything looked distorted with "expand" and "expand appearance". – Raquel Fantasia Feb 15 at 2:46

protected by Darth_Vader Mar 25 at 13:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.