Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I can't seem to apply graphic styles to objects if they're behind a clipping mask.

I encountered this problem when I wanted to use graphic styles in order to change the fill colour of a symbol instance that contains a clip group. It is the same with clip groups that aren't within symbols.

Is there a way to apply graphic styles to symbol instances containing clip groups?

Here's an screen shot of the symbol layers:

enter image description here

share|improve this question
    
Are the styles object styles or group styles? Are you aware that there are two different Graphic Style types? –  Scott Aug 29 '13 at 13:56
    
I wasn't aware of this. Following your answer to another question I applied fill and stroke colour to a group and dragged it to the Graphic Styles panel. There it appears devoid of such colouring, and indeed the Appearance panel for the originating group doesn't list it either. I then applied that style to my symbol but it didn't change appearance. I also tried it on groups with clipping masks without using Symbols with the same result. –  seron Aug 31 '13 at 18:16

1 Answer 1

There are two possible solutions that immediately spring to mind.

1. When you apply a graphic style to a clip group (or a layer), the styles may appear BENEATH its contents - and the effect is therefore entirely hidden.

You can re-order the contents/effects so that your graphic style is applied on top - do this via the appearence panel. Here's an example;

Contents are displayed on top of graphic styles

Here you can see that there is a graphic style applied (green and yellow pattern) - but that it's not visible, and instead we're seeing the blue patterned contents.

In the appearance panel, 'Contents' appears ABOVE the two fills that have been applied (as a graphics style) to the layer.

Compare that to the following picture ..;

Contents moved below graphics style

By dragging the contents below the fills (and/or strokes, etc, if applicable), the graphic style is now visible.

2. Your other option is to apply the graphic style to your contents - as opposed to the layer or clipping mask. The simple way of doing this if the layer or clipping mask is selected, is to click on the 'Edit Contents' button (see the image below).

You will most likely find that graphic styles will now work as expected (famous last words ...).

If you look in the appearance panel, you will see that your selection will have changed to one or more of your content items - and the graphic styles will be applied directly. It may be that you DON'T want to apply the styles to your contents, but if this is not an issue (or is otherwise desirable), this is an easy way to accomplish this.

Edit contents of layer or clipping mask

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.