Sign up ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I am designing an A1 poster (at 300 dpi) and am noticing blurriness on a pixel pattern when I export my PSD to PDF.

My methodology for generating the PDF is as follows:

  • Flatten the image
  • Save as -> PDF
  • Options: Do Not Downsample, compression: ZIP

These screenshots are both taken at 100% size.

This is the view when editing in Photoshop.


And this is the output from the PDF

Output PDF

The first concern is that the sizes are not identical, I don't know whether this is Photoshop or Adobe Reader.

The second concern is that the pixel pattern is not sharp and is instead meshed together, am I doing something wrong here?

share|improve this question
By default Reader/Acrobat displays pages at "fit to page". Are you viewing the PDF at 100%? Why are you flattening before saving as PDF? – SOIA Oct 9 '13 at 19:26
Hi @Scott, Yes I am viewing the generated PDF at "Actual Size". I am flattening to reduce the PDF's filesize and the time it takes to open the PDF - I just tried to export before flattening and unfortunately see the same results as above. Thanks – Pete Oct 9 '13 at 19:40
If you are worried about file size then you should possibly consider designing the poster in InDesign and what other elements that cannot be created in either InDesign or Illustrator use Photoshop. – Darth_Vader Oct 9 '13 at 19:50
I'd need to see a sample of the PDF or the Photoshop file (just a section) but I suspect what you see in the PDF is merely the PDF display in Reader. If you go to the preferences and uncheck "Smooth Images" and "Enhance Small Lines" the display may improve. – SOIA Oct 9 '13 at 19:57
Thanks @Scott, I've tried changing those settings but it still looks like the above. I've tried changing the pattern used from 4x4 to 8x8 and the output looks much sharper but the size is still the same as above. I guess that the issue is to do with the output size, either Photoshop's preview is wrong or it is resizing the document at export? – Pete Oct 9 '13 at 20:18

1 Answer 1

It's unclear if your issue is the text being blurry or the images. But let's assume your images have the right resolution and were not resized bigger, or didn't lose any quality in that way.

If the texts are blurry, you can cheat and convert your PSD layer file to PDF, and still keep the sharpness of a vector.

From the screenshot that is still visible, it looks like a question of text trapping in Photoshop. You can fix this in 2 ways:

First Option: Don't flatten the text layers in Photoshop before exporting!

Let Photoshop flatten the layers during the export by checking the "as a copy" box while you export in PDF.

This way you will keep the "vector" properties of your text depending on the Photoshop version you use. When you flatten the whole layout before exporting, it rasterizes everything together.

You can keep the same settings for compression as the ones you already mentioned.

The examples below are both screenshots from Acrobat PDF:


Second Option: Convert that Photoshop text to vector

Simply save your file in .psd with the layers, and open that file in Illustrator. Choose the "convert layers to objects" and your text layers from Photoshop will be transformed into vectors.

How to keep the text in vector in Photoshop without rasterizing it or flattening the layers when exporting to PDF?

Now export that PDF with the highest quality setting or no compression at all, and open it again the way you took your screenshots to see if the issue still happens.

If you're satisfied, you can follow these instruction to optimize your PDF to be a smaller file size but retain the same print quality:

"Adobe PDF file too big, what are my options?"

Other Option: Add some trapping in Photoshop

If you don't own a license of Illustrator or simply don't want to use it, or you're using an older version of Photoshop, you could try to add some pixels to your trapping on your text. This will hide the anti-aliasing you might see on the final result but it will not improve the quality of your file Some colors don't blend well together and this will at least hide a bit the effect of anti-aliasing between the colors. It doesn't do miracles and your text and whole layout will still be a raster image.

To do this, go on the menu "image" and select "trap". In this box, add 1 or 2 pixels of trapping. Usually 2 gives good results.

Don't forget to keep another version of your Photoshop with layers; trapping like this will require your to flatten your file and you also need to be in CMYK color mode!

This is slightly destructive, it's good for some situations but if you can, it's better to convert your PDF to vector or use the first option above.

About PDF size/dimension

Acrobat doesn't open by default at 100% or fit to page; it depends on your preferences or the setting in the PDF as well. But you seem to have understood this already.

One reason why your PDF could look like being a different size than the Photoshop is the resolution set in the Adobe Acrobat Preferences.

Acrobat PDF size resolution ppi

Depending on what you have there, the "real size" of your PDF will vary on the screen. It's also normal

For example, the example below are the exact same PDF at 500% in Acrobat. The example on the right is using 72ppi display resolution in Acrobat and the one on the left is using 101ppi. I'm not certain but I think by default it's possible your page display is set to the system setting.

pdf size difference in resolution display

If you want to see the exact same size in Acrobat and Photoshop, and that your Photoshop file is a 300ppi, try to insert 300ppi in the Acrobat resolution setting. The 2 documents should be shown at the same size.

how to make adobe acrobat pro pdf show same size as psd exported file pdf

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.