Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have a simple question. I was reading this tutorial. And I couldn't get the effect as expected. After some experiments I found that when I merge two shapes and apply stroke only its outline gets a stroke. For example I draw 2 rectangles and merged them. This is what I got: enter image description here

I would like to have stroke also inside the shape. How to do this?

EDIT: This is what I got doing above tutorial

enter image description here

What is expected:

enter image description here

My path options:

enter image description here

share|improve this question
1  
errr.. don't merge the shapes. –  Scott Oct 25 '13 at 15:25
    
@Scott Actually its not about merging. I want to do some "Transform again" to get a spirograph effect. So when I do it, its automatically gets merged. –  rahul Oct 25 '13 at 15:29
    
It shouldn't get auot-merged if the shape layers are separate layers and the path option are set correctly. –  Scott Oct 25 '13 at 15:32
    
@Scott Can you please take a look at this photoshoptutorials.ws/photoshop-tutorials/special-effects/… I'll update what I got doing that. –  rahul Oct 25 '13 at 15:36
    
Rahul, the starting shape layer needs to be a layer by itself, not merged. Then everything works as the tutorial explains. –  Scott Oct 25 '13 at 15:38

2 Answers 2

up vote 0 down vote accepted

Before drawing your first shape, be certain the path options are set to "New Layer"

new layer

This will not cause the shapes to be merged, but rather each shape will be its own layer. You can then add layer styles as needed to each layer.




UPDATE: Figured out your issue.

  • Draw the first shape
  • SWITCH TO THE MOVE TOOL
  • Now, proceed to do the transform to rotate then the step and repeating.

If you don't switch back to the Move Tool then the path stays active on the same live shape and the paths merge. When you transformed to rotate you were getting a pop up message about a Live Shape being converted to a regular path, weren't you? that would have been a helpful clue.

share|improve this answer
    
"New layer" is already selected :( –  rahul Oct 25 '13 at 15:53
    
Then I don't know what to tell you. There should be no "auto-merging" taking place. Each shape should be its own layer. –  Scott Oct 25 '13 at 15:55
    
What about "Transform"? Isn't there a "step'n'repeat" style effect you can apply using offsets and n copies without cluttering up document with 120 (etc) layers?. –  horatio Oct 25 '13 at 16:02
    
Its ok,thanks for help @Scott. –  rahul Oct 25 '13 at 16:19
    
@horatio is step and repeat accessed by Alt+Ctr+T? It also merges shapes. I dont know whats wrong. –  rahul Oct 25 '13 at 16:21

I am using an earlier version than you or Scott (as far as I can tell), but I can reproduce the behavior.

In my case, a shape is represented on the palette as a color layer and a layer mask. When I hit ctrl+alt+shift+T (hereafter "the Key"), I get one new layer as expected HOWEVER all further repetitions of the Key are all pasted into the same single shape mask and the stroke is applied to the merged shapes.

The problem for me is that the after hitting the Key, the new layer's shape mask is highlighted which is why the new shape is pasted into the mask instead of creating a new layer. If I deselect the mask by clicking on it, then the Key creates a new layer.

The key combo for selecting the bottom layer is alt+, and the key for selecting the top layer is alt+.

Try ctrl+alt+shift+T alt+, alt+. repeat.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.