Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

Look at iMac mockups on this page.

Quality of skewed screenshots placed in the mockups are poor. Seems like photoshop knows too little about super-sampling.

I know how to render a 3d model in 3dsmax with good supersampling, but it's a much more tedious work. How can I make screenshots look good in photoshop? 3D layers? Maybe vanishing point? Smart-objects seem to be rendered poorly, very bad supersampling I mean.

share|improve this question
    
supersampling at its simplest is achieved by rendering with at least double the desired end resolution and then downsampling. Try starting with screen captures that are twice the pixel dimensions you plan on using in the final product. Also, as I understand it, if you can do your perspective/distort + scale in a single step, you will have a better result. –  horatio Oct 31 '13 at 21:24

2 Answers 2

up vote 2 down vote accepted

I think it's the perspective which is inconsistent in your link, not the screenshots specifically. This seems more prevalent in the lower 3/4 screenshot. There's no attention to the existing iMac perspective, only the top edge angle.

enter image description here

Vanishing point would certainly help this.

There are many tutorials for Vanishing Point. And the entire point of the Vanishing Point filter is to match perspective of an existing photo.

Adobe Help: http://help.adobe.com/en_US/photoshop/cs/using/WS714a382cdf7d304e153d0941004907be29-7ff5a.html

PSD Tuts: http://psd.tutsplus.com/tutorials/photo-effects-tutorials/getting-to-grips-with-the-vanishing-point-filter/

Photoshop.com: http://www.photoshop.com/tutorials?keywords=vanishing+point

I don't think you need actual 3D.

share|improve this answer
    
You know how to make precise perspective? I tried vanishing point but it gave similar results. –  Maxim Artyushenko Oct 31 '13 at 20:24

How Photoshop interpolates an image when scaling is affected by the current default setting in Image > Image Size.... With CS6 and CC, leaving it on "Automatic" usually works adequately, but if you're not getting the result you want, try changing it to something explicit, such as Bicubic Sharper.

Since you're familiar with 3D, try 3D > New 3D Mesh from Layer > Postcard and see if that doesn't give you a better result.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.