Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I just downloaded the trial version of CS5, haven't modified any settings at all so it's vanilla. After starting it up I hit CTRL+N for a new image, select the defaults, but all I see is the gray background of CS5 itself. If I move the canvas window onto my desktop I see through it and see whatever is behind the window. However, while moving the canvas window I can properly see what's on the layer, which, is just a blank white canvas as I have not done anything to it yet. I can make brush strokes, which still don't show up but again if I move the canvas window around I can see it on the white canvas as it should look.

So, how do I disable this mysterious canvas 'transparency'?

share|improve this question

migrated from stackoverflow.com Jun 3 '11 at 10:12

This question came from our site for professional and enthusiast programmers.

    
Did you ever find the answer? I've had CS5 for quite awhile and this just started today. Seems the same problem as you had! I've tried restoring my computer to a date where it was working fine- and that didn't fix it, either. On the same computer- I can log in as my husband and see the windows- but not logged in as me. –  user2128 Aug 6 '11 at 23:07
    
(1) Have you trashed your prefs per Alan's answer? (2) Are you using multiple monitors? –  Farray Aug 6 '11 at 23:43
    
I have this problem also - it only happens when I have my second monitor attached using HDMI. Haven't found a solution yet other than not using my second monitor. –  user2945 Nov 21 '11 at 0:46
    
I tried the HDMI connection recommendation. I disconnected my extra monitor and voila! Glad I didn't go through all the other steps first. –  user9638 Jan 30 '13 at 14:37

11 Answers 11

up vote 5 down vote accepted

There's something off with the installation. You don't what platform you're on, but from the description it sounds like OS X. You should double check that your system meets the requirements for Photoshop, but I'm going to assume it does.

Your first (standard, when PS goes weird) troubleshooting step is to reset the Photoshop preferences (yes, even on a clean install it's sometimes necessary). To do that, click the icon to launch Photoshop and immediately hold down Cmd, Option and Shift (Ctl, Alt and Shift on Windows). Answer yes to the dialog that pops up.

Try turning off Open GL and GPU acceleration in Preferences > Performance. If that clears up the problem, update your graphics driver.

If that doesn't do it, uninstall, then before you reinstall clear out your caches and repair permissions (see OS X help for the steps). Restart the OS, and reinstall.

If that still doesn't clear it up, try setting up a new user account and installing it there. If everything works normally in the new account, the problem is with corruption in your regular user account.

In the doomsday scenario, where none of the above worked, you may need a fresh OS install. You can test that using an OS X install on an external drive.

share|improve this answer
    
I'm running it on Windows 7 Professional 64bit. Resetting preferences and turning off Open GL and CPU acceleration didn't fix the issue either. This is rather weird. –  Jamie Taniguchi Jun 8 '11 at 20:00
    
It's very strange. At this point I would uninstall, reboot, run a good registry cleaner, reboot again, and reinstall. First, though, do ensure that you have the latest version of your GPU driver. There were severe problems reported in the beta forums with a recent ATI driver (11.5, from what I recall), allegedly fixed now. I'm on Win7 with an NVidia GPU, so I can't verify that. The tip about setting up a separate account is also good for Windows. –  Alan Gilbertson Jun 8 '11 at 20:19
    
Uninstalling and using a different trial installer other than the one from Adobe seemed to work. Not sure why the official one would have caused this. –  Jamie Taniguchi Aug 8 '11 at 11:44
    
Resetting my preference file worked for me on Mac OSX 10.7.5 with Photoshop CS 5.5. Thanks. –  program247365 Jan 26 '13 at 20:05
    
Just resetting the preferences worked for me. I tried manually deleting the plist but did work, however the Cmd-Option-Shift worked. –  Michael Ozeryansky Mar 26 '13 at 1:12

im having this issue too, with CS 5.5. The only solution I found so far is to disable my second monitor, then open Photoshop, then re-enable my second monitor. Its a HORRIBLE solution. I was looking for something better, like a FIX. I should be able to use PSD with two monitors extended.

share|improve this answer
    
Welcome to GD. It sure would be nice if Adobe had better support for multiple monitors, eh? –  Farray Feb 7 '12 at 0:52
    
To fix the problem, Adobe needs to know about it. Has anyone tried posting this problem to the Adobe Photoshop forum or the Photoshop Family Customer Community (it's technically hosted under Photoshop.com, but it appears to be a GetSatisfaction community for the entire Photoshop family line of products)? –  Lèse majesté Feb 8 '13 at 7:24

I have that problem too, one sullotion is to change the screen resolution to a lower res, then bring the canvas into view and change the resolution back.

share|improve this answer

Check your OpenGL settings and the garphics card - http://kb2.adobe.com/cps/404/kb404898.html

share|improve this answer

i had this same problem. Try to using preset like the U.S. Paper or one of Photoshop preset sizes. it worked for me but im not sure what causes this problem.

share|improve this answer

First check for updates though the Help > Updates... menu. Then try this: If you have two monitors and what i suspect happened is that the art board or canvas got stuck on the other monitor also got moved when changing screen resolution sizes. So when i used the computers screen toggle and i disabled the second monitor while photoshop was open it fixed the issue because it brings everything back to my primary laptop monitor. :)

share|improve this answer

I had the same canvas invisibility problem, but mine was with CS4 on Windows 7, and I don't use a dual monitor (I teach and 3 out of 34 computers had the issue). I just opened a new document in PS and changed the screen resolution, and it worked. W00T!

It's a good thing I did that before uninstalling and reinstalling.

share|improve this answer

I had the same problem. For me, it was a plugin panel opening in my workspace when Photoshop opened. I solve the problem by closing the panel and problem sorted. (Win 7 x64)

share|improve this answer

I don't know exactly whats happening to your cs5 but you should try pressing f for some time,or press tab, might be your options are hidden try these two things might be they will help...

Most Thing depend on version 32 bit and 64 bit ?? which version you downloaded?

Same issue discussed on adobe form please check

share|improve this answer
    
I'm running the 64bit version with the latest nVidia drivers. I'll have to try the patch. –  Jamie Taniguchi Jun 8 '11 at 19:59

Sounds definitely like a graphical bug... have you tried reinstalling? The other two answers are good things to check up on as well.

share|improve this answer
    
I've tried reinstalling twice and had the same bug. –  Jamie Taniguchi Jun 8 '11 at 19:59

I found the answer! At least to my problem, which was I couldn't see the canvas or even when I clicked File->New.

Go to Window and click Application Frame.

Everything re-appeared. Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.