Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

Anyone have clever solutions for drop-shadows from InDesign that are being uploaded in .pdf to a website? I've just learned that the new Firefox built-in reader doesn't support it, known issue (Mozilla Support showing issue).

I tried PDF/X-1a which fixed the shadow issue but one of the more complex sections gets thin white boxes around objects. Same thing when I just opened the PDF and did a Print to PDF.

Only other thing I can think of is opening each page in photoshop, flattening, and combining which obviously isn't ideal for text quality or workflow. This is only an 8 page document so I could do it. Thought maybe one of you knows a solution.

share|improve this question
    
You can also check your PDF Export > Advanced > Transparency Flattener settings, but if you specified PDF/X-1a, it should already be set to the highest setting. –  apex Nov 15 '13 at 23:23
add comment

1 Answer

up vote 3 down vote accepted

Option 1

To allow text to still be searchable as text, you could take all of your graphic elements into Photoshop to flatten and re-import back to InDesign as a bitmap image background.

Option 2

Or, if you don't care as much about the selcectable/searchable text, a quicker route would be to open your PDF in Acrobat Pro, and File > Save As Other > Image > JPG. This will save each page as a separate JPG file to a folder you specify.
Then just click File > Create > Combine Files into a Single PDF and grab all of those JPGs you created.


Ultimately though, it sounds like a known Firefox viewer problem. Any 'solution' is really just a workaround to better support users on that browser.


EDIT

If using Option 2, you can adjust quality settings by clicking the Settings button below the filename in the Save As window:
'Save As' window
...and then adjusting the quality settings (in red), and perhaps even the resolution settings (in yellow) if additional clarity is required:
JPEG Settings window
Increasing these settings will obviously result in a larger file size, but will also make your text more readable. For maximum clarity, you'd want to go with Option 1 though. Although more time consuming, you'll get perfectly legible text at a fraction of the filesize compared to having rasterized text (like in Option 2).

share|improve this answer
    
Doing it this method doesn't give enough control over image quality. Whether I do jpg or even tiff the text ends up being way too low resolution. –  Ryan Nov 19 '13 at 13:55
    
@Ryan - Please see my revised answer for additional information on improving the readability of your document. –  apex Nov 19 '13 at 20:56
    
thanks but I already played with the settings, its just not a good enough text quality. I'll mark this the answer anyways since it may help someone else. –  Ryan Nov 19 '13 at 21:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.