Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

Ok, so keep in mind that I have no idea what I’m doing with image editing.

I have a watermark that I want to add to images, but it loses it’s transparency when I try to stick it on a picture. I’ve tried the watermark as RGB and as greyscale. I read through the GIMP discussion site and found an answers that gave three possible methods (here), but I still couldn’t get it to work. (I didn’t understand the “Channels dialog” part of the second and third methods, and for the first method, I couldn't get the floating selection anchored in the mask.)

This can't be a hard thing to do - I feel like there’s something very basic that I’m just missing.

Can anyone help?


EDITED to add images that I'm using. the image that I want to watermark: here's the image I want to watermark; the watermark: and here's the watermark; and the end result: end result

Thanks for any help!

share|improve this question
    
It seems that your sushidragon overlay image does not actually have a transparent background, but a white shape. Looking at the image in a browser on a non-white background shows this quite obviously. You need to remove that white shape such that only transparency is left. You can find numerous tutorial on how to remove a white background in GIMP, this is one example. –  Bart Arondson Jan 29 at 18:44
    
Thanks for getting back to me! The watermark is intended to have that little winged shape. Here's an example where the watermark is functioning properly: link –  user19299 Jan 30 at 23:24
    
But my problem is that the watermark is too opaque. –  user19299 Jan 30 at 23:37
    
Have you tried using a different blending mode for the watermark layer? Or you could change the opacity of the watermark layer. Other than that I think the transparency of the watermark got lost in some conversion you've done on the watermark. I don't know, maybe someone more knowledgeable has an answer. –  Bart Arondson Jan 31 at 0:43
    
Found the solution and figured I'd post it in case anyone was having the same problem: the original image was set to INDEXED and needed to be changed to RGB. Easy enough to fix! –  user19299 Feb 6 at 14:53
show 1 more comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.