Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

I'm using Adobe Illustrator CS6. I can get you pictures if you need but here goes.

I had a logo that I cut in half by removing anchor points, leaving me with just the left side.

Then I selected all the anchor points along what will be the new center line using the Direct Selection tool. Then I tried to align the anchor points in a perfect vertical line using the Horizontal Align Right option in the Align tab.

Then, I selected the entire path. Went to the Appearance tab, clicked Layer and then applied a Distort & Transform > Transform using the X Reflect.

Everything worked beautifully except I have this very fine white line down the center of the image now. How do I get rid of it?

share|improve this question
    
Images would be very good! –  Random O'Reilly Feb 6 at 13:11
    
Zoom in and make sure that the line actually exists. Illustrator sometimes renders things kinda funky. If that's the case, and it bothers you you can also select both sides and use the pathfinder tool to unite the two sides together. –  Johannes Feb 6 at 15:58
add comment

4 Answers

up vote 1 down vote accepted

(Looking at sample file.) You get a white line because the white object is not aligned with the back objects.

Align the left edges of all objects if you wish the reflection effect to be flush to the right. -- line was a guide.

Upon further examination, it appears to be more an issue with smooth points being used where hard corners should be and the fact that the anchors on the right do not all line up. In addition, there are several stray anchors.

  • First, select all and choose Object > Path > Cleanup tick all 3 boxes you see there and click OK. This will remove the stray points.

  • Next, select all the anchors on the right of the image... Only the right-most anchors.

  • Click the Convert to Corner Point button on the Control Bar. This will set all those incorrect smooth point anchors to actual corner points.

covert to corner

  • Then set the Align Panel (or Control bar) to Align to Selection.

enter image description here

  • And lastly click the Align right button on the Control Panel.

alight right

This will ensure all the anchors on the right side of the image are in perfect vertical alignment and eliminate the white gap.

You may still see a hairline rule of white but as you zoom in, that will disappear. This is due to anti-aliasing... read here for more on that.

share|improve this answer
    
Okay, I didn't realize there was a white object, how can I select it? –  Dex Feb 6 at 22:20
    
Fantastic Instructions. For some reason it still is not working for me. I did the cleanup but still found a number of overlapping anchor points, which I deleted manually. The gap is now smaller but does not disappear completely when I zoom in to 6400%. New file after your instructions: copy.com/WkrNe4vVfBQ7Mrku –  Dex Feb 6 at 23:42
    
That's simply an anti-aliasing line (see link in my answer). If you go to Preferences and unchecked Anti-alias artwork.... the line disappears. I'd also suggest you apply the effect to the Group rather than the layer. The line will not be present then either. You really should avoid layer targeted effects as much as possible. They can't be expanded and can often cause confusion and issues later. There's no viable reason you need to apply the effect to the layer as opposed to the group. While Adobe allows effects on layers, I've never found any need to apply them there. –  Scott Feb 6 at 23:47
    
You're right. Thanks for the help. I'm pretty confident in PS, but AI a whole new beast to me. –  Dex Feb 7 at 0:00
    
Glad I could help :) –  Scott Feb 7 at 0:04
add comment

Perhaps the two anchor points aren't absolutely exactly lined up? Just asking because you said you 'tried' to align them manually. If you have a newer version of Illustrator (starting with CS4 I think) you could select just the two anchor points with the Direct Selection Tool (white arrow) and using the alignment tool, align them exactly.

Or it could simply be a display problem. If you zoom close in, does the white line disappear, stay the same or get larger? If it gets larger then the anchor points aren't perfectly aligned.

To definitely get rid of it you should close the path and make both halves one object, either by selecting two open points and joining them with Ctrl+j, or if they definitely are perfectly aligned, by using the pathfinder palette.

share|improve this answer
add comment

If I understand you correctly, this is how I would accomplish it, being sure that the lines are straight:

Consider this blob the logo:

enter image description here

Make a shape - here a box - that covers the bits you want to keep, select both, then go to object -> clipping mask -> make:

enter image description here

Voilá, you have half a logo you can continue working with:

enter image description here

share|improve this answer
add comment

Okay, now that you have posted the file I see what's wrong.

You have an actual space there in your image.

Here's how you fix your issue:

  1. Select your image
  2. Right-click and select Isolate Selected Clipping Mask
  3. Now select either the left or right side of your image and move it so that the gap is closed.

That's it! Your image will no longer have this gap.

You may experience a thin line that "appears" to be there but is in fact not (you can test this by zooming all the way onto the line.)

share|improve this answer
    
Your answer seems easiest to follow but I'm still having issues. Using the Selection Tool (V), I click on the black area, but I only see the option Isolate Selected Group. It also does not select the detail at the tip of the nose. If I do select it by holding shift and clicking, the only option I get is Make Clipping Mask. –  Dex Feb 6 at 22:33
    
@Dex, mine may be different as I'm using an older version of Illustrator. You'll probably want to select Isolate Selected Group -- in regards to the nose just make sure you have that selected as well, or simply group it with its respective side. –  Johannes Feb 6 at 22:35
    
For some reason I still can't get it to work. When using the Selection Tool (V). I do still see a slight white space around the edge no matter what I do. –  Dex Feb 6 at 22:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.