Sign up ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I Use Google Sketchup Pro 2013 for modeling in 3D, and then I export said models into Cinema4D for Rendering and tweaking the textures applied in Sketchup. Most of the time it works, but on the odd occasion it doesn't export into Cinema4D as it looks in Sketchup.

Recently I made a building in Sketchup based off of a real life picture from a client, and after about 3 days of solid work I'm finally finished the model. When I opened the .3DS file from Sketchup in Cinema4D, though, almost none of my materials are importing correctly if at all, and when I try to reapply the materials to the areas which don't have the right materials I end up applying materials to the wrong areas as well as the ones I meant to. Below is the model I noted earlier and the version of it in Cinema4D;

The Green plane underneath the house was going to be grass in Cinema4D, but when I attempt to apply a grass material to it it ends up applying it to the whole driveway.

Notice how none of the textures are to scale or are even aligned to the axis they are supposed to be aligned to.

I've tried everything within my mind to fix this- I've exported under every possible format and setting but to no avail, and nothing in Cinema4D can seem to fix this either. Is there any way to import a model directly from Sketchup into Cinema4D and have the model look exactly as it did in Sketchup as it does in Cinema4D?


PS. All answers are appreciated as this is a very urgent question!

share|improve this question

4 Answers 4

up vote 2 down vote accepted

First, COLLADA is a terrible format for 3D model interchange. Yes, I know this is what it was designed for, but I have almost never gotten two unrelated programs to agree on every detail about how to interpret a given COLLADA model. There's always something screwed up after the transfer. Sometimes it's something small enough that you can clean it up and move on, while other times it's bad enough to crash the app you try to load the model up in.

(I touch on related matters in a different question.)

I have never achieved "painless," but with some grunt work and patching, I've often achieved "eventual success." Call it moving the goalposts, if you like, but I believe this is the state of the art, as we find it today.

It's been several years since I had to do this, but I believe my best results for SketchUp-to-C4D were done via OBJ format using the Riptide Pro plugin. In an ideal world, we wouldn't need the plugin, since C4D nominally supports OBJ out of the box, but the fact is that Riptide frequently gave me a better import (or export) than C4D's built-in support. I suppose it is possible that C4D's built-in OBJ support has gotten dramatically better in the past few years, but I wouldn't bet on it.

A better bet might be FBX. Although this is a closed, proprietary and undocumented format, it has one very important virtue: Autodesk offers a free SDK that 3D app developers can use to transfer assets into and out of this format. I'm only aware of one other competing implementation of FBX, and that one was created purely for licensing reasons. This means you have the uncommon case where almost every 3D app that supports FBX is using the same software library, which which eliminates a large source of idiosyncratic incompatibility.

You don't say why you want to import into C4D. If all you want is access to a photorealistic rendering engine, there are a bunch of add-ons and connectors for SketchUp that do this.

The one I see advertised everywhere is LumenRT, but I haven't tried it.

What I used instead, the last time I needed to do this, is OTOY's Octane Render coupled with the SketchUp plugin. They want 379.00 € for this today, but I was using it back when Octane was a US $99 beta product and the SketchUp plugin was freeware distributed on the Octane forum. It worked quite well even back then, so I assume it's only gotten better.

There are many other options.

Regardless of the rendering plugin you use, you should find that it is far more reliable than a export-then-import path because the plugin is specifically designed to turn the SketchUp model into rendered pixels.

Export-then-import has a bunch of sources of impedance mismatch that you don't get in the plugin case.

First off, you're working within the confines of the Venn Diagram of Sadness:


Except in uncommon cases like FBX above, the exporter and importer implementations won't support all the features of the interchange format, and the interchange format certainly doesn't support all the features of the source or the destination app. This leaves you with a tiny overlapping area. Anything that falls outside that area doesn't transfer correctly.

Second, the two apps probably don't agree on basic facts about the 3D world, like which axis is "up", or whether 1 unit of 3D space equals 1 foot, 1 meter, or something totally arbitrary like the Poser Native Unit.

share|improve this answer

For many decades people post such conversion questions on forums and the questions are answered with commonly incorrect information. As the father of the CAD + DCC conversion industry, there is only one proper way to achieve such conversions, such as SketchUp <--> Cinema-4D in this example.

First, the primary rule I explain everyday is that the free converters that come with all 3d software is poorly implemented or non-functional. Most people do not believe this fact since they place great trust with the 3D converters then "they paid for". Unfortunately, developing fully implemented and error free conversion software is much more expensive to achieve that such software vendors wish to allocate people, money and time towards.

As per the comments posted above: the 3ds file format has long been obsolete for 15 years or more. It is an old 1985-era 16-bit DOS file format which came from the old $40 CAD-3D and Antic Animator software on the Atari|ST platform. It is guaranteed to corrupt your conversions, as it has no ability to convey the accurate vertex normals, it is limited to 65k polygons/vertices per object (16-bit computers from the 1980s), it uses 8.3 DOS filenames (and hence all your texture map filenames will be truncated), it uses 10 character object & material names, etc. It is often hard to believe how many people still believe that the .3ds file format is some kind of "conversion standard" when that is far from reality. I know of this information well as I personally wrote the first and only full implementations of the .3ds file format in 1987 (.cd3d) and 1993 (renamed to .3ds).

As for COLLADA, it is quite a good file format, but politically motivated as was FBX and U3D. Technically, it is aligned to being a "3D gaming" file format but it would suffice for cross conversion. The problem again is that few 3D companies, at all, can allocate the people, time and money to developing full-blown 3D importers. COLLADA is on the more complex side for import parsing.

To address the main question of "Painlessly export from Sketchup Pro 2013 to Cinema4D R15 Studio", I and my staff have spent hundreds of man years writing the one & only professional conversion system which handles all 3d file formats on an engineering-level of quality. We worked with the original SketchUp developer 11 years ago before he stopped working on SketchUp, allowing us to create our PolyTrans-for-SketchUp conversion system. And for the last 20 years we have been MAXON's sole conversion provider. Hence, we provide 100% complete conversion to/from SketchUp and Cinema-4D. No need for the use of lossy intermediate file formats like OBJ, 3ds, FBX or COLLADA. We also completely pay for all of the software via our steep government subsidies, keeping it at only US$395 for our entry level SketchUp customers.

Now, since our software is not free I am all too familiar that it is not applicable to most SketchUp users. However, it is the one & only such dedicated conversion solution and available for those on forums who continue to ask why no dedicated conversion software exists....

share|improve this answer
Hi Robert, welcome to GDSE and thanks for your answer. If you have any questions, please see the help center or ping one of us in the Graphic Design Chat once your reputation is sufficient (20). Keep contributing and enjoy the site! –  Vincent Sep 16 at 9:40

I suggest you to rename the .kmz file in .zip, you will find a collada model inside the archive :-)

(Or you can export from sketchup using "export for material" in the 3ds export options)

share|improve this answer
Thanks, though I did try this with the model in question and it didn't work either. I guess I just had an awfully made model. –  Ben Franchuk Jul 18 '14 at 23:40

You may actually export a Collada File (DAE) directly from Sketchup. Use that file format to import your model into C4D. But be carefull that all your geometry in your sketchup file are well defined. (no back faces are looking outwards, and no faces are overlaping each other.)

share|improve this answer
yeah, I tried every format and the model still never exported as it was in Sketchup, so I'm pretty sure it was a problem with the geometry. I still get this problem too, with textures not being on the right faces and the like, even with the most recent versions of both sketchup and cinema4d, however I've now found that this can be easilly fixed by modifying the polygon selections associated with the misplaced textures in cinema4D. Its a lot of work on the big models, but at least i can still use them in my work instead of having to scrap them due to this error/glitch/problem. –  Ben Franchuk Jan 11 at 3:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.