Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have a weird thing happening with this font. It's Avenir. I've used it in the past with no issues, but this one seems to pop up once in awhile. The issue if not obvious is that some letters appear larger than the others. The 'C" and the 'G' for example.

Any ideas?

I'm using a Macbook Pro

type issues

share|improve this question
5  
Rounded characters are traditionally slightly larger than their square counterparts. It's done intentionally to counteract the visual size variation which occurs due tot he rounded tops. –  Scott Apr 4 at 18:37
    
Avenir seems to conform to that, probably 1-2 pixels height difference in larger type sizes ( linotype.com/43930/AvenirStd95Black-product.html ) Just scroll down until the "C" touches the top edge of the browser viewport. –  horatio Apr 4 at 18:43
    
They seem too big to me, for that to be the reason. I am guessing you guys are pointing to the effect demonstrated on Palatino here? i.stack.imgur.com/RFyMf.png –  Benteh Apr 4 at 23:40

2 Answers 2

This can happen when the type is used at sizes not supported in the hinting. It's essentially a display error. When you print it's gone. Even exporting to PNG or jpeg will fix it in some cases. Other than that, the only fix is more complete hinting.

share|improve this answer
1  
Would this particular instance benefit from setting the type larger, rasterizing the type layer, then scaling? Or perhaps a smart object with larger type scaled down. –  horatio Apr 4 at 20:59
    
That's a darn good question. I've never tried. –  plainclothes Apr 4 at 21:13
    
I'd imagine rasterizing the type layer would do the trick –  SaturnsEye Apr 8 at 15:53
    
Yes, rasterizing then down scaling haywire hinting does sort out hinting issues, but there are easier solutions: try different anti-aliasing mode like "crisp" or "strong", or try a size that's a rounder number (e.g. 22 instead of 21.5, or 24 instead of 23) –  user568458 Apr 9 at 12:11

I sort of fixed it by changing the display method in Photoshop. I had anti aliasing method set to 'crisp' I changed it 'sharp' (or vice versa) and it cleaned it up.

share|improve this answer
    
Glad you got it sorted! You can set your own answer to the accepted one. Be good for future reference. –  Benteh Apr 8 at 15:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.