Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm saving an Illustrator CS6 file as a PDF. The file has a transparent background, however when exported as a PDF and dropped into InDesign the file has a white background.

I've tried saving the file as different types of PDF but nothing has worked.

This is a recent problem that I've not had an issue with until the past two weeks.

Can anyone give any suggestions?

share|improve this question
    
Hi Sam, the background looks white because that's what the PDF associates as "transparent". It will still be transparent. – SaturnsEye May 1 '14 at 8:23
    
The background isn't transparent though as when I put it into InDesign over the top of an image it has a white square box background, even when viewed in high quality. – Samantha May 1 '14 at 8:26
    
This method is working fine for me with PDFS and InDesign. How are you importing the PDF to InDesign? – SaturnsEye May 1 '14 at 8:28
    
I know, it has worked for me too for as long as I can remember but for some reason there is a problem now. I'm saving an Illustrator file as a PDF then importing it into InDesign. I appreciate your help. – Samantha May 1 '14 at 8:32
    
I'm currently working so will not be able to I'm afraid. If you think of any suggestions please let me know. – Samantha May 1 '14 at 8:38

It seems that you're placing the PDF ignoring its transparency. In the file selection window shown when the “Place” command is used, there's a checkbox (near the lower left corner of the window) “Show Import Options”. When checked it'll cause the said “import options” window to appear. Make sure that the “Transparent background” is selected there.

share|improve this answer

You are saving the image correctly but the white background is showing because there is a setting for it in Adobe Reader, follow the below steps to remove the white background from your PDF.

  1. Open Adobe Reader.
  2. Press CTRL + K or go to Edit > Preference and check the box, which says show the transparency grid (Please check the image below for clarification.).
  3. Open the saved PDF with transparent background.

enter image description here

share|improve this answer
1  
How is this the most upvoted answer? It’s clearly not relevant to the question. The asker is placing her PDF into an InDesign document; Acrobat Reader does not enter into the picture at all. – Janus Bahs Jacquet Sep 29 '15 at 23:57
  1. File>Place (ctrl+D) To replace the pdf again into Indesign.

  2. This time check the "show import options" box. enter image description here

  3. In the next window check the "transparent background". This way you will create a default rule, so next time you place a pdf image without "show import options" checked, the object will be importet with transparency. enter image description here

Done.

share|improve this answer

You have to make sure that the pictures is linked directly to the images. Else will it be white-boxed-background instead of transparent!

// MP

share|improve this answer
    
What exactly is this supposed to mean? That the pictures are linked directly to the images? What is the difference between a picture and an image here? Are you talking about the placed object having to be properly linked to the actual PDF file for its transparency to show up? That is true, but it doesn’t seem like that’s the problem here, considering that the asker specifically says that she places the PDF file by FilePlace, which means the link should be all right. – Janus Bahs Jacquet Sep 30 '15 at 0:01

You will have to re-place the pdf again into Indesign. This time check the "show import options" box. Make sure you check the "transparent background" in the next window. This way you will create a default rule, so next time you place a pdf image without "show import options" checked, the object will be importet with transparency.

thebodzio is right, it doesn't have to do with adobe reader

share|improve this answer
    
Can you please add some screenshots to show the boxes to be clicked ... – Kurt Mar 7 at 14:46
    
I would if i knew how to upload images in comment... (I'm new in here) 1. file>place (ctrl+D) 2. check "show import options" box 3. check "transparent background" box done – Dritan Lleshi Mar 9 at 10:20
    
Add it to your answer. Because you have low rep, delete the leading !, one with more rep can activate it for you. – Kurt Mar 9 at 10:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.