Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I need to import data into a table in InDesign (CS6). But i keep getting the same value in every single cell, what am i doing wrong?

1). I start by making a .csv file in OpenOffice with some test data

Table in OpenOffice

2). I created a table in Indesign CS6 and selected the .csv file generated by OpenOffice and started filling the table with the titles enter image description here

3). When i click preview or press create merged document it keeps placing only the first row of the .csv sheet. enter image description here

I would love to get some tips on this.

Thanks in advance,

Rick

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You're not missing anything. Datamerge is not able to make true tables by itself. It is great for making things like contact sheets or business cards or labels etc. things that repeat the same layout over and over. It is not good at putting data into an Indesign table.

There is a free script that may be useful in getting this into a table for you found here. True Indesign Tables using data merge with a script

If you don't have linked images as part of your datamerge your other option would be to save you file as an .xlsx file and place it into your document (check the show import options if you want more options). Indesign will convert that to a table that you could then edit and style.

share|improve this answer
    
Didn't expect this to be a problem for InDesign ;-) Thanks for your tips! I will try it with the script. –  R2K2 May 12 at 20:47

Adding to Evan's excellent answer, it's worth pointing to the other problem with your approach is the common error of inserting multiple instances of each field in your layout, instead of using Data Merge's Multiple record feature.

When you place the same field multiple times, you'll get the first record in the dataset multiple times. It's somewhat counter-intuitive, but you have to place only one instance of each field on the page and change "Records per Document Page:" to "Multiple Records". Then you can use the "Multiple Record Layout" tab to specify the position and spacing of the repeating (but now different!) records.

This procedure does have problems, however, as this recent question highlights.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.