Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

Using Adobe Illustrator CS6, I drew a line and clicked the "Dashed Line" option in the stroke palette.

When I change the length of the dashed line, by grabbing an endpoint and moving it or clipping it, the size of the gaps and dashes in the line change. I don't want that to happen. I checked the various boxes in the Transform options but nothing helps.

How do I keep the dashes and gaps consistent in a dashed line?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Try the "Preserve exact dash and gap lengths" option in the Stroke Panel. It's the left-most of a pair of illustrated buttons, just to the right of the "Dashed Line" checkbox.

Preserve dash length

share|improve this answer
1  
That did it! I've used this program since ver. 8 and can't believe some of the tools and tricks that I've missed that are right under my nose... THANKS! –  JeremyH Jul 9 at 20:29

In the Transform Palette side menu, turn off Scale Strokes & Effects.

You can also turn it off in the Preferences. Hit Command + K and uncheck it in the General tab.

share|improve this answer
    
I do have "Scale Strokes & Effects" unchecked. The size of gaps and dashes still change. –  JeremyH Jul 9 at 19:54
    
hmm, that should have fixed it. Are there any other effects applied to the line? –  Rsiel Jul 9 at 19:56
    
I checked the appearance palette and don't see anything else added to the line other than stroke. –  JeremyH Jul 9 at 20:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.