Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I've never really found a solution to an issue that's been plaguing me since I first experienced it in Photoshop CS, and now, five versions later, it's still bugging me!

What is it? Well, seemingly randomly, Photoshop decides that when I use the solid fill bucket, or the pencil tool to "paint" something within a marquee selection, it will either "feather" whatever I'm doing to the pixels outside of the marquee, or "anti-alias" the inside border pixels of the marquee.

Sometimes, I actually want this to occur, but it doesn't regardless of what I do (and I end up using the eraser tool with a low opacity to recreate it) and then sometimes, when I really don't want it to occur, it does.

Here's an example screenshot of what I'm talking about: alt text

See how it's randomly added pixels outside of the select? (The selection was drawn with the poly marquee tool, with feather set to "0" - the green colour was added with the pencil tool, with normal mode and opacity set to 100, and size set to 70px).

This MUST be a setting somewhere that I've totally missed, and it's driving me barmey!

Please could you advise me on how to disable anti-aliasing in Photoshop?

share|improve this question

migrated from photo.stackexchange.com Nov 20 '11 at 2:18

This question came from our site for professional, enthusiast and amateur photographers.

    
With 0 feather and anti-aliasing unticked, I can't make this happen in CS4 or CS5.5 (windows). The only way I could make it happen was making a no anti-alias selection then transforming it (e.g. stretching it feathers in the direction it's stretched). It'd be useful to hear which versions this seems to happen and which it doesn't, and if there are any clues as to when it seems to happen –  user568458 Apr 5 '12 at 8:54
    
how about color decontamination? maybe its related to that but not sure which settings are involved there –  user24216 May 26 at 3:24
    
The "problem" is that a selection in PS is not binary. –  b1nary.atr0phy Nov 15 at 3:54

6 Answers 6

up vote 6 down vote accepted

Firsly feathering and anti-aliasing have different meanings, though for small a feathering radius the results are similar. "Feathering" effectively means fading the selection boundary out slowly, and is slightly different to "anti-aliasing" which means using intermediate values to smooth out jagged edges.

You need to turn anti-aliasing off in addition to setting the feather to zero to get what you want, which is a sharp rigid boundary. There should be a checkbox in the tool palette, next to the feather radius box:

alt text

(screen shot is from a very old version of Photoshop!)

It's worth noting the black and white "marching ants" selection border only ever shows the 50% threshold of the selection, and is therefor just a guide. If you save the selection to an alpha channel you can see the selection opacities of every pixel, and thus see your actual selection.

share|improve this answer
1  
sorry - I should have mentioned that both feather and Anti-aliased options were set to zero / unticked, so it's not that :(. However, have up-voted for the second paragraph, of which I was NOT aware! –  Sk93 Oct 20 '10 at 14:48
    
Ok in that case it sounds like a bug. If you save the selection to an alpha channel do you get any pixels which aren't pure black/white? You might be able to tell by looking at the histogram. I'll see if I can reproduce the problem myself. –  Matt Grum Oct 20 '10 at 15:44

Surprising, you're quite correct and there seems to be no way of preventing it from happening, even with no feathering, no anti-aliasing and the tolerance set to zero you still get additional pixels.

You can invert the selection and delete most of the anti-aliasing but some still remains inside the selection.alt text

//edit I added the example below, the anti-aliasing is most pronounced at the points on the top - I screen shotted so you can see the selection area. This was done in CS5 using the paint bucket tool.

share|improve this answer
    
Can you describe the exact steps you used? I tried to –  Matt Grum Oct 21 '10 at 8:36
1  
Can you describe the exact steps you used, along with software versions etc. I had a go in CS4 using the lasso tool and paintbrush but was unable to reproduce the problem. Also what does the selection look like as an alpha channel? I'm trying to determine whether the problem is with the selection tool or fill tool... –  Matt Grum Oct 21 '10 at 8:40
    
I've added a brief description and example to my answer, let me know if you need more. This was done with the lasso tool, but the same thing happens with any kind of selection, but the angles in the selection above show the problem best. –  toomanyairmiles Oct 21 '10 at 19:00

This isn't really a bug; it's just how Photoshop handles selections. Selections are alpha masks in Photoshop CS+, and they behave as such, so they can have pixels that are only 1/127th selected.

One way to workaround this is to make your selection and fire up Select > Refine Edge and throw the contrast all the way up to 100%. It's not perfect, but it does a pretty good job.

Refine Edge

share|improve this answer
    
Even though selections are alpha masks it's possible to have a mask containing only values 0 and 255, which is what you should obtain when feather is 0 and AA is turned off. In fact this is exactly what I get with these settings. The fact that I can't replicate the problem described here is what makes me think this is a bug. –  Matt Grum Oct 23 '10 at 23:11

Another way to get rid of feathering is to use the Image > Adjustments > Threshold. You will have to merge the selection layer onto a layer that is filled with white. Then make the Threshold adjustment. This will give you a mask to remove the feathering.

share|improve this answer

It seems that "feather" must also be unchecked in the settings of the selection tool you use to make the selection

share|improve this answer
2  
feather AND antialias must be unchecked/set to 0 –  Nicolas Nov 28 '12 at 21:17

Right Click Selection > Stroke 1 px.

Magic Wand > Adjust Tolerance > Fill Inside

In some cases you must make the path first and then follow those steps while making the stroke with the pencil.

share|improve this answer

protected by Matt May 26 at 17:01

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.