Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

I have a non-filled rectangle with some border color. "Inside" this rectangle I have some other objects (the type of the objects doesn't matter for my problem, it could be text, other rectangles, ...). Between those "inside objects" and my outer rectangle there's a lot of space.

Sometimes when I select the "inside objects" the outside rectangle is also selected, but I did not select it with my mouse! It is selected "automatically"?! Is this a bug or a feature? If it is a feature, where can I disable it :-)

They are not grouped, I use the mouse ("draw" a rectangle around the objects to select them; no shift key, no lasso, no wand)

share|improve this question
    
Are they grouped? HOW are you selecting? Direct Select? Lasso? Wand? –  Scott Jan 6 '12 at 19:48
    
Updated my question ^^ –  strauberry Jan 7 '12 at 7:47
    
So by "draw a rectangle" you are clicking inside the outer shape... does it have a fill? –  Scott Jan 7 '12 at 8:03
    
Exactly, I'm clicking inside the outer shape (which is NOT filled) and drag my mouse around the "inside objects" –  strauberry Jan 7 '12 at 8:45
add comment

2 Answers

up vote 2 down vote accepted

Okay.. based on comments above....

If you include the center point in your drag-selection, then the outer shape wil be selected. Remember, it's not merely the outside path that defines the shape, there's also it's center point.

If you drag a selection of multiple objects like so....

enter image description here

You also select the center point of the outer shape...

enter image description here

You can disable the center point for objects by selecting the object then toggle the center point visibility in the Attributes Panel.

enter image description here

share|improve this answer
    
Yeah, great man :-) This is the reason, thank you very much! –  strauberry Jan 7 '12 at 9:00
add comment

It sounds like you may just be accidentally selecting it. The easiest way to stop this if you have your rectangle in a fixed position is navigate to the layers panel and simply click the box by the eyeball to lock the layer. Now no matter what you do, you won't select it unless you unlock it again in the layers panel.

share|improve this answer
    
Thank you for the hint to lock the layer, I use this feature quite often. The thing is, that I do not accidentally select the rectangle! It is not filled (not with white!) and there are about 300 pixels space between my "inner" elements and the rectangle –  strauberry Jan 6 '12 at 15:18
    
that is strange. It may just be a bug with this version of Illustrator –  Julian Baughman Jan 6 '12 at 21:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.