Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

This seems to have happened all of the sudden; When I try to add any effects besides color and gradient overlay to any given layer, that action has no effect on the canvas. I've tried the opacity sliders, changing the effects' colors, and pretty much anything else I could think of, to no avail. Anyone have a suggestion?

share|improve this question

migrated from photo.stackexchange.com Jan 30 '12 at 20:31

This question came from our site for professional, enthusiast and amateur photographers.

A screenshot of your layers palette might be helpful. Additionally, a more detailed explanation of the layers present and the blending modes and layer styles applied to each would also be very helpful. –  jrista Jan 27 '12 at 5:24
Are you new to photoshop, or experienced in CS4/CS5 and thinking there is something wrong/different with 5.5? Are you applying effects as adjustment layers or directly to a layer? –  MikeW Jan 27 '12 at 9:54
First off, I solved the problem – I just reset Photoshop's preferences file (I didn't lose more than two minutes' keymapping). I am moderately experienced in Photoshop, but far from mastering it. In retrospect, this should be under Graphic Design. And finally, the layers panel looked completely normal, with the layer with styles applied displaying all said styles, on top and "Transparency shapes layer" turned off. –  Jules Mazur Jan 27 '12 at 17:44
If you solved the problem, might as well post an answer as an answer, and mark it accepted. :) –  mattdm Jan 27 '12 at 23:52

2 Answers 2

I've found the solution to this problem on the other site. Check if the small "eye icon" isn't greyed out. If it is you have the same problem I had. The solution for me was Layer → Layer Style → Show All Effects.

here's a : link to where I found my solution (possibly NSFW language)

share|improve this answer
This is the real answer. –  nathan742 Nov 19 '14 at 5:49
up vote 2 down vote accepted

Turns out that I just had to reset Photoshop's preferences file. Now everything's back to normal and working perfectly.

share|improve this answer
This is just a last-resort solution. @Jezior answer is the real solution. –  nathan742 Nov 19 '14 at 5:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.