Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

My displacement filter is simply broken. I made the simplest possible grid for a test subject, and then a displacement filter which is solid 50% grey. This should, as a displacement map, do absolutely nothing. But when I apply it, it produces the transformation shown below. It's moving the lines around, fading then, and it also adds horrible pixelation in the middle. This from a map that should have no effect at all! What's causing this and what can I do about it? Thanks.

Test Pattern Test Pattern Displaced

Update: Here's a PNG of the displacement map, as requested (sorry it's so boring, but I did say it was a totally neutral map):

enter image description here

share|improve this question
    
Have you tried resetting preferences/settings? –  Scott Feb 5 '12 at 22:33
    
Could you upload a PNG of the displacement map? –  Lèse majesté Feb 6 '12 at 1:58
    
@Lèsemajesté: Yes, I've updated the question with a PNG of the map. –  Joshua Frank Feb 7 '12 at 1:26
    
@Scott: I just tried it now and the same thing happens. –  Joshua Frank Feb 7 '12 at 1:29
    
Who made the down vote, and why? –  Joshua Frank Feb 7 '12 at 1:53
show 2 more comments

1 Answer

when I take your grid, and then create a 2-channel displacement map, I can mimic your problem using the following:

(-50,-50,tile,wrap around)

Channel 1, Channel 2: (The filter image looks plain grey, even when exporting)

enter image description here enter image description here

Final image:

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.