Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I am working on a very basic InDesign project (my first one), and have one trouble that is progressively driving me crazy.

I need some bold text, and so have added a 0.25pt black stroke to my 10pt text where needed. However, when exported to .pdf, I end up having a sort of white stroke. It looks as follow:

enter image description here

I tried to export in various Adobe formats, with or without transparency flattening. I tried opening the file with various reader versions.

I tried several conversions:

  • InDesign → JPEG → PDF from the JPEGs (not recognized as valid format)

  • InDesign → PDF → exported as JPEGs → JPEGs combined to new PDF (not recognized as valid format)

  • InDesign → PDF → combined to PDF (you never know)(didn't work, lines still there)

  • InDesign → PDF → PrintToPdf (lines still there)

The worst part being than when I print, it looks perfect, the white lines are not there. But I need to send the file as a pdf, and it will be mainly seen this way, so I can't afford it displaying that way.

So, what could cause that? How to prevent it?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Adding strokes to text to create a feux bold is really bad practice. It would be a much better solution to use a typeface which actually has a bold face.

Check the Reader prefs... Page Display > use Overprint Preview [dropdown] Set that to "Always" It may help the display. Unfortunately, you can't control how other users have their prefs set. You can tell them to make this same switch. But really, the only sure-fire way to prevent this is to use a proper typeface.

share|improve this answer
    
yes, I ended up finding another almost similar bold font, and making a character style making it look more like my initial one. I read online that using strokes was the best way to get a bold text, I guess I will learn for next time. So there is no way to have InDesign save a "what you see" version? Like a really flattened image, without strokes or other things? –  Cristol.GdM Feb 13 '12 at 3:02
    
Well, indesign assumes you're creating content for either digital delivery or printing. If printing, Indesign utilizes overprinting where appropriate. Overprinting is not the same as transparency so flattening doesn't really factor into overprinting. I suspect if you had exported the PDF as a digital PDF the issue may not have been present. But without knowing the specific reasons you need a PDF it's difficult to recommend that method. Especially since the resulting digital PDF can be drastically different in nature. One thing is certain.. adding strokes to text is always a bad idea. –  Scott Feb 13 '12 at 3:27
    
I guess that if you did need to use this technique, you might be able to add a fill as well? Might this give better results? –  e100 Feb 13 '12 at 10:43
1  
Well, you can't add a fill on your text, unfortunately. Or rather, the base color is already considered the fill, so you are stuck with base color + stroke. –  Cristol.GdM Feb 13 '12 at 13:05
add comment

I understand that it is bad practice to try and make faux bold text in any program, whether Photoshop or Illustrator or Indesign. I understand it, but it is also not realistic to an artist. Sometimes you like fonts that don't have a bold option, but they need to be more readable. What do you do then? So it isn't good to apply faux bold in Photoshop because it is rasterized, however, in Illustrator and Indesign, it is all vector, so I do not see any problem with it.

So, I think I've been able to get around this weird issue with white lines showing up in the PDF when exported. I just Outlined the Type. (This is under Type > Create Outlines) That seems to get rid of it. The type is still vector, it just isn't editable. That's why you always keep an editable version around and go back to it if you need, then re-outline the text. It works for me and no need to choose a different font! Yay!

I hope this helps someone!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.