Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

I am creating an animated sprite list in illustrator. I finished creating the sprites and used the "Horizontal/Vertical Distribute Center" commands to distribute the objects equally in some area.

But if the objects are too spread apart, the "Distribute Center" tool leaves, albeit equal, much distance between the objects. The opposite is true: if the objects are too close then distributing them will just overlap them.

My question is, is there any tool that just puts objects side by side? I imagine that this tool would work if the objects aren't even equal in size. If I'm not clear, please tell me I might just add photos and screen shots to further clarify.

Thanks.

I have viewed this question and answer but it is not what I need: Specifying distance between objects in Adobe Illustrator CS5

share|improve this question
    
Help! One of the side effects of having Illustrator assign the distance between the objects is that when I animate the sprite according to the sprite sheet, the animation is broken. –  Mzn Feb 15 '12 at 11:53
add comment

1 Answer

up vote 10 down vote accepted

You can align to a specific dimension (horizontal or vertical) using the "Distribute Spacing" selection in the "Align" tab.

enter image description here

Select the objects you want to distribute, single-click on one object to set it as the anchor object, and enter the amount you want them distributed. Click on either the distribute vertically or horizontally button.

You can also use this to place two objects exactly next to each other; just set your spacing to "0".

share|improve this answer
    
Oh my, this answers the question perfectly. I have some objects on glow, is there a way to include these in the calculated image width/height? Because Illustrator doesn't take them into account if I set distance to zero and the glow overlaps. Please augment your answer with such information. Thanks a lot. –  Mzn Feb 15 '12 at 15:37
    
Well, if you add the glow radius to the spacing it might solve that issue... –  lawndartcatcher Feb 15 '12 at 16:57
    
yeah that's what I did. just one simple extra step :) +1 for follow up :D –  Mzn Feb 15 '12 at 17:14
    
If the "Distribute Spacing" buttons are not there, then you must click in the top right corner of that little window and select "Show options". Then it will appear. –  mangledorf Jan 16 at 21:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.