Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I am working in Illustrator (15.0.2 (CS5) or 16.0.0 (CS6)) and when I try to move objects small distances, they snap to the nearest two pixels on some invisible grid. I can't find anything in the preferences. Here are some screen shots:

move issue

share|improve this question
    
You can manually move the object to that location. Using the arrow keys will result in a 1px change, meaning if you're working on a partial-pixel level, it will move further than you may want it to. –  Johannes Feb 16 '12 at 4:02
    
Did you try turning off all snapping under view? –  DC_ Feb 16 '12 at 4:20
    
Possible duplicate: graphicdesign.stackexchange.com/questions/5689/… –  Scott Feb 16 '12 at 4:24
    
yup, that was one of the first few places i looked. I think it SHOULD be there... its weird that its in the transform panel! –  AndyPerlitch Feb 16 '12 at 5:15
    
Thanks for this answer. I was starting to doubt my mental health has i couldn't find a way to stop this weird behavior. You need to know that you have to check or uncheck that option for every object on your canvas. That option doesn't control the document but a single selected object. To make it even more weird, when using a shape to crop another shape, the two halves would automatically reposition themselves. To avoid this behavior in the transform window you need to deselect the "align new objects to pixel grid" option. Hope this bit of information will help someone else from going mad and –  user4309 Apr 17 '12 at 12:23

2 Answers 2

up vote 25 down vote accepted

For new objects, turn off "Align to Pixel Grid" on the Transform panel.

transform panel

For existing objects, select them first, then Turn off Align to Pixel Grid.

share|improve this answer

It was driving me crazy too... you can deselect the Align to Pixel Grid checkbox on the Transform panel (shows up on "show options"), but new objects will always retain the snapping behaviour.

To turn it of permanently, click on the flyout menu at the top right of the transform panel then uncheck Align new objects to pixel grid.

Phew...

share|improve this answer

protected by Community Sep 15 '12 at 16:42

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.