Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

This is in a file originally created in this version and installation of Illustrator CS4.

I have a simple text item, with one character in it. Alternately, I pick a drawn element, doesn't matter.

I have the Selection Tool, i.e. the all black arrow. I'm not touching the keyboard. I click on the object (selected or unselected, doesn't matter), and drag, the cursor changes to the copy object version, and it copies the object. But I want to move it.

Illustrator knows properly what mode my keys are in, it does the right thing if I type in option-e e to get a é.

share|improve this question
1  
Odd. Now, this doesn't remove the actual problem, but what if you option-drag the layer? I mean, as this normally copies the dragged layer, could it revert your action to normal? –  koiyu Jan 26 '11 at 7:15
    
I'm not sure what you mean. I tried getting into the layers panel, and option-dragging the layer callout there, and it simply didn't move, and nothing happened. When I simply dragged it, it pulled on outline which snapped back, since I have just one layer. –  Hack Saw Jan 26 '11 at 8:17
    
If I option-drag the object, it copies it, as you'd expect. –  Hack Saw Jan 26 '11 at 8:18
    
What OS (including exact version number if on Mac OS X)? –  NSGod Jan 26 '11 at 16:27
    
Hmmm, coulda sworn I mentioned this earlier. OSX 10.6.6 –  Hack Saw Jan 27 '11 at 6:50

2 Answers 2

After a visit to the Adobe forums and trawling around there for a while, I saw someone with the opposite problem who solved it by logging out. It was worth a shot, it's not something I do often.

This fixed it.

Thank you to everyone who offered me suggestions, I do appreciate the support.

share|improve this answer
    
+1 When in doubt, reboot. In fact, I reboot every Monday morning as a matter of course. –  Philip Regan Jan 28 '11 at 11:02
    
My brother the IT guy says if any problem can be solved by restarting, rebooting, or logging out and in again, you have to put a quarter in his Guru Jar. That usually takes out a third of the problems people would otherwise bring him. –  Lauren Ipsum Jan 28 '11 at 14:22
    
As an longtime computer guy, I hate problems that are fixed by logging out. :) –  Hack Saw Jan 28 '11 at 19:44

Some troubleshooting ideas:

  • Does this happen in other files you created in this version and installation?
  • Does this happen in files originated on someone else's machine?
  • If you copy this file to someone else's machine, does it happen there?
  • If you copy the contents of the file to a new file and save it under a new name, does it still happen? (don't just save-as. Select all, copy, new file, paste, save.)
  • You said "option" so I'm guessing you're on a Mac. Did you check in System Preferences --> Universal Access to make sure you didn't turn on a helper key by accident? (I've done that with the zoom on occasion — scares the crap out of me when my text suddenly blows up to 4000%.)
  • In the same vein, are you clicking with the correct side of the mouse or the correct mouse button? (that is, you're not right-clicking when you mean to left-click, or holding down the right mouse button at the same time that you're dragging.)
share|improve this answer
    
Does it happen to other files: Yes –  Hack Saw Jan 26 '11 at 2:26
    
Universal access: Universally off –  Hack Saw Jan 26 '11 at 2:27
    
Right side stills shows a context menu, no nope, they aren't switched. –  Hack Saw Jan 26 '11 at 2:28
    
I can't test the other machine ideas, but I also don't know what that might tell us. I can say this: It's happening on files where it didn't before, so I don't think it's a per file thing. –  Hack Saw Jan 26 '11 at 2:29
1  
Other machines can confirm that the problem is on your machine, rather than part of your files. If you can, go more drastic: uninstall and reinstall Illustrator. –  Lauren Ipsum Jan 26 '11 at 13:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.