Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for professional graphic designers and non-designers trying to do their own graphic design. It's 100% free, no registration required.

I'm using Photoshop CS4 and have a project where I'm using a layer/section of brushed chrome and another adjacent layer/section in charcoal carbon fiber (pattern) background. On the CF layer, I'm adding a text layer which is in color. If I start the project in RGB mode, it prints out with a purple cast on both the metal and the CF. If I switch to a Greyscale mode it prints out fine, but now I can't use the red colored text which was created in RGB mode. How do I add RGB elements (layers) to my Greyscale layered image?

share|improve this question
add comment

2 Answers

I think kamalo gives good advice, but "prints out with [color cast]" implies that the printer might be the culprit here. Many printer drivers have color over-saturation (sometimes called "photo enhancement" etc) turned on by default. You probably don't want this. Try turning it off.

In addition, greys are usually built up with colors instead of just black and if you have an absorbent paper (like regular office paper) the different colors will spread and be absorbed at different rates, so the color balance will drift resulting in color casts.

share|improve this answer
    
Thank you both for the help. OK... I don't have much control over the printer as I'm having something printed out a 48" wide HP InkJet off-site, and its being printed on gloss photo paper. Everything else I have had printed comes out great, just the brushed metal look seems to get that purple caste to it. I changed to greyscale and they printed out a quick sample and the metal looked perfect but of course I can't have color in the image or on certain layers. So to Desaturate all I do is click on the Desaturate in the dropdown while I'm highlighting that particular metallic layer? –  Mike Mar 30 '12 at 20:28
    
You can place an adjustment layer under the colored text so that anything below that adjustment will be affected, and everything above will not be. Use "hue/saturation" adjustment and then slide the saturation setting all the way to the left. The adjustment layer can then be toggled on or off without destroying any information in the layers below it. Note that a layer mask can also be applied to an adjustment layer. If this works for you, go ahead and mark kamalo's answer as accepted. –  horatio Mar 30 '12 at 20:45
add comment

Your layers need to be in the same mode. Rather than changing the mode of your .PSD to turn it into black and white, desaturate your background then put your text in a new layer on top while keeping your document in RGB.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.