Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

My Eyedropper has suddenly started changing all samples to white. No matter what area of an image I click it samples white, this is regardless of sample size or modifier keys. If I manually select a color with the Color Picker, and then sample an area of the image with the Eyedropper, same result, white. All of my other tools are working correctly. I tried resetting the tools, I verified my documents settings are correct, I restarted Photoshop, restarted the computer...nothing.

Any ideas?

share|improve this question
    
It corrected itself after I selected and used the Measuring Tool, which shares a space with the Eyedropper on the Tools palette. If anyone has additional info to add then please do so. If not I'll answer it myself, or we can flag it for closing. Weirdest bug I've ever experienced. –  user4204 Apr 4 '12 at 23:47
    
Similar to the clipping mask suggestion, if you have a layer effect applied that changes the colour, you may need to select a different option on your picking tool, or copy the layer, merge/flatten, get your colour, delete. –  DumbNic Aug 24 '13 at 13:37
    
what was wrong with the way eyedropper worked in previous version? where is quick mask mode? what is it? why are these new features getting in my way? –  user1043568 Nov 5 '13 at 13:35

2 Answers 2

It's tough to answer with any certainty since you yourself aren't sure and now the problem is resolved.

If this happened in only 1 photoshop file, it's very likely that you had a layer mask selected instead of the image layer. If this were the case, your eyedropper would be selecting the mask values (and if the mask wasn't actually masking anything out, it would be all white).

share|improve this answer
    
Yup.. layer mask must be highlighted. –  Scott Apr 5 '12 at 0:34
    
Nope, no layer mask was applied at the time. Nice tip though. –  user4204 Apr 5 '12 at 13:48

Just found out the answer: quick mask mode

if your in CS6, there's a button at the bottom left hand corner of the toolbox with a dotted circle in it, click it, and you'll be able to select colours again

share|improve this answer

protected by Matt Nov 5 '13 at 14:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?