Take the 2-minute tour ×
Graphic Design Stack Exchange is a question and answer site for Graphic Design professionals, students, and enthusiasts. It's 100% free, no registration required.

I have half-US Letter (8.5" x 5.5") documents I print out in booklet form from Adobe InDesign CS5.5 on a Brother 9970CDW color laser. Works great.

Problem is InDesign doesn't allow you to print booklets from InDesign book files (why not?!). So I have to export to PDF and then print the booklet from Acrobat. Then the issue is I get slightly bigger margins all around (with slightly scaled down pages) for some reason. I've tried fiddling with every setting I could think of to get rid of those margins...

It's clearly not the printer's issue of having too big of margins as this prints fine from within InDesign. The Brother printer is able to print pretty close to the edges (closer than I need).

share|improve this question
1  
You don't have "fit" ticked in the print window for Acrobat do you? –  Scott Apr 10 '12 at 18:30
    
There is no "fit" type options. I think that's the problem, Acrobat doesn't allow you to control scaling or margins at all if you do booklet printing. So it seems booklet printing in Acrobat is fairly useless. –  at. Apr 10 '12 at 18:59

4 Answers 4

up vote 1 down vote accepted

One of Acrobat's (and Reader's) little gotchas is scaling. By default, the Scaling field in Reader is set to "Fit to Printer" and in Acrobat X, which calls this "Size Options," it's "Fit". This reduces (or increases) the size of the document to the "right size for the paper and printer." What Acrobat considers to be the right size is, frankly, anyone's guess. The Acrobat team build their product primarily for document distribution and automation, not so much for the design community. Suffice that for most any design task, the default output size will be wrong.

In the case where Acrobat isn't giving you a choice, booklet printing, you have a couple of different things you can try, having made sure that "Actual Size" or "None" is selected in the regular scaling section:

One is "Print as Image," which you'll find, bizarrely enough, in the "Marks and Bleeds" section of the "Advanced" printing dialog. Use the maximum dpi available. This is most often used to work around problems with Postscript interpretation and transparency, but it can work to avert unwanted scaling also.

Another is "Print to File," located right beside "Print as Image." (You have to wonder about these UI decisions.)

A third is simply to select "Adobe PDF" as the printer.

In the latter two cases you would use that file to actually print the document. This isn't as oddball as it sounds; when working with high-end laser printers using Fiery controllers, it is common to run the document through the Fiery RIP and save the resulting output file in the printer so it can be reprinted on demand without having to open the original file. In that case, though, booklet printing is built into the controller.

share|improve this answer
    
You may be right, the issue is, when printing a booklet within Acrobat/Reader there are no "Size Options" or "Fit" settings. –  at. Apr 10 '12 at 21:49
    
That's right, I wasn't thinking it all the way through. Revised answer. –  Alan Gilbertson Apr 10 '12 at 22:54
    
Where exactly is the "Print as Image" option? The only place I found it is by clicking the "Advanced" button near my printer drop down menu. However, if I click on it and then ok, when I go back to "Advanced" it's unclicked (tried many times of course). –  at. Apr 11 '12 at 0:57
    
regarding printing to a file, when I try to do so within the "Printer" dialog, I get the following error in Adobe Reader X: "Saving a PDF file when printing is not supported. Instead, choose File > Save." –  at. Apr 11 '12 at 1:17
    
Should work fine with Acrobat. I don't have Reader handy to test with. If you're on a Mac, there was a change that came in with Snow Leopard that broke the print-to-PDF workflow, to the intense annoyance of many designers. You have to output as Postscript then run it through Distiller, and I'm sure you can't do that from Reader. –  Alan Gilbertson Apr 11 '12 at 2:29

This is what seems to be happening in Acrobat X and Reader 11. The printer (in my case a laserjet) has an unprintable area around the page - 6mm or so - which is part of the paper size definition. Acrobat trims this 6mm from whatever you want to print which effectively reduces your Letter size of 216mm x 279mm to 204mm x 267mm, and then it scales this so that when you print the 204mm x 267mm area of your page is expanded/magnified to fit on 216mm x 279. I found a solution to be to define my own custom paper size to be 216mm x 279mm (i.e. Letter size) and tell it the unprintable area was 0mm all round.

So here goes. Create a custom paper - I call it Lettersize - in the page setup menu, 8.5 by 11 inches, with zero unprintable area. Use this custom paper when you want to print the pdf in Acrobat (10.7.1) - again, in the page setup menu (which Acrobat tries to dissuade you from using). Choose Actual Size in the size options (I also put Page Scaling: None in the File/Document Properties/Advanced Window). Here's the funny thing: Choose the Auto portrait/landscape option (!) for orientation. And the pdf should print exactly as it appears on your screen.

share|improve this answer

I found a freeware command-line program a while back that can "bookletize" a pdf called pdfbklt. AFAIK, it was written in perl, so there are probably versions of it for linux, mac, etc. Unfortunately, I do not know where to find it online since I archived it locally a few years ago.

I have used this for little personal projects (not production) and it has worked well enough for my purposes. I usually make up a 8.5x5.5 page document as reader spreads (8.5x11 two up per page), create a pdf, and then use the command line tool on a copy of that pdf since it alters the document you give it.

Run the program with no options to see the command line arguments available. I use pdfbklt.exe -b ltr -l -p 2 %1

This does NOT handle creep, so you will need to factor that in manually (!), depending on your needs and document size.

share|improve this answer

I just found out how to print books in InDesign. Here is the link:

http://help.adobe.com/en_US/indesign/cs/using/WSa285fff53dea4f8617383751001ea8cb3f-704ba.html

share|improve this answer
1  
Hi Jennifer, and welcome to GD! Can you please add information from the link to understand how this answers the question? Links can disappear, so it's important to add as much possible to the answers. Also, people with the same issue shouldn't need to be redirected to find what they are looking for. If you have any questions regarding how this Q&A site works please see our faq. Also, you can find some answering advice here. –  Yisela Mar 4 '13 at 4:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.